JIRA workflow actions not appearing

We are experiencing an issue where tickets at a certain point in their workflow cannot be advanced, because no workflow action buttons appear. I have checked the Conditions for one of the actions that should be possible (Because I thought I'd start with getting -one- button to appear) and the only condition set is a single "Only users in project role" restriction. I checked that project role, and the correct people are in it, but still can't see the button. I also tried setting the "Role" in the restriction to "Users" (which contains essentially everyone) but still the button does not appear.

Where else can I look for potential reasons for a workflow transition button not appearing?

2 answers

1 accepted

This turned out to be an issue with the transition TO the state that wasn't showing the transitions, rather than a problem with the transitions themselves. The transition to the 'problem state' had issues as a result of a validation step that used an out of date plugin - uninstalling it resolved the issue.

Can you clarify how you resolved the problem? I have a similar problem that just started few days ago. The workflow was changed 7 days ago to remove a pre-condition (requiring all subtasks to be closed). The users do not see the transtion to take the issue from In Work to Pending Build. Ignoring the names of the buttons, if this was your situation, was the problem in the 1st state (In Work) or in the 2nd state (Pending Build)?

Note that I ran system integrity checker and it found no problems. I did a comparison (eyeball) of the previous workflow and the current workflow for the transition in question and the only difference is the removal of the 1 pre-condition as expected.

Note, I found an Atlassian knowledge article that solved my problem. I had to remove and re-add the role-based permissions. We are using JIRA Misc Workflow Extensions plugin. Atlassian: Workflow transitions do not work after upgrade

1 votes

Is this happening for all issues or just one or two? If it is the former, there must be something in the workflow that is wrong.

If it is the latter, use the integrity checker to find out if the issues are somehow in a wrong state or not.

It's happening for all issues in a particular state in a particular project/workflow, so I agree that there must be something wrong with the workflow, but it seems so simple that I don't know what it could be, so I was hoping for some suggestions as to where else to look besides just the Conditions restrictions.

Also, this appears to be happening since our upgrade to 5.2.11 (from uh...something old like 3.5ish.) - anyone aware of anything like this happening?

Hmm. Update. Looks like there might be a problem with an EARLIER step in the workflow, because trying to push a ticket through to the problem state gives an error. Digging in on that.

The plot thickens; So, when we try to move the ticket to the step in the workflow where the transitions don't appear, JIRA throws an error:

[webwork.util.ValueStack] METHOD: "promotedLinks", exception:java.lang.NoSuchMethodError

Now to figure out why that happens...

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,075 views 13 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot