JIRA not taking the Emails

Frank May 30, 2018

This issue is on and off. I followed the below troubleshooting..

Checked the Email Request under Applications>> Service Desk

Test gives me "

No problems found with email settings configuration. Successfully connected to the specified email server.

Logs says ServiceRunner Messaging Error when MailPullerWorker pulls emails from help@abc.com: Couldn't connect to host, port: outlook.office365.com, 993; timeout 50000

JIRA-Bootstrap Updated mail connection id 5 with parameters help@abc.com help@abc.com outlook.office365.com imaps 993

ERROR [] Caesium-1-2 anonymous Messaging Error when MailPullerWorker pulls emails from help@abc.com: A3 BAD User is authenticated but not connected.

 

Here is my configurations details. We have 4 POP / IMAP Mail Servers listed in Incoming Email(it has help@abc.com details with different server name and username). Attached Image 1

 

Email.JPG

 

 

 

3 answers

1 vote
Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 31, 2018

That specific error message is known to happen when Jira is using IMAP with a shared mailbox on office 365.  There is a KB on that error in: A3 BAD User is authenticated but not connected error message when using JIRA with Office365

From that KB:

Cause

  • JIRA does not support IMAP integrated with a Shared Mailbox.  This feature suggestion has been closed as there are no current plans to build it:  JRASERVER-30688 - IMAP login to a shared mailbox RESOLVED

Workaround

 

I hope this helps.

Frank May 31, 2018

@Andy Heinzer Thanks. I checked it and someone in the comments mentioned it is working with IMAP? 

0 votes
laralg
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May 31, 2018

Hi Frank,

Are you talking about Mail Handler or normal Jira Service Desk email configuration? Because that looks like a mail handler to me, which usually does not have anything to with how Jira Service Desk mail is configured, in fact I would not recomend configuring both of them for the same project...

Frank May 31, 2018

@laralg Thanks for responding. Yes, I see the same email in IMAP/POP Incoming settings page and in service desk for one request type. 

laralg
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June 1, 2018

Jira is a bit delicate when working with mails. Make sure your Jira installation can reach the mailbox and try first with a normal email (even your own email would work) before trying shared accounts or mailbox. I usually find it works better with a single email in the same domain as the one configure for sending mails.

0 votes
Frank May 30, 2018

@Noel Howell @Nic Brough -Adaptavist- and other.. Please help me

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