Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA Service Desk: Issue being auto shared with organization

Hi Guys,

Am a new user so sorry if this is a stupid question.

I have setup an Organisation (a client of ours) and setup around 10 users for them. I have a problem now when one user logs a ticket, JIRA automatically emails out to all 10 users which can be very annoying for all the users.

Have i configured something wrong? I have set the email notification on the issue received to be onlt the reporter and not Customers Involved but still happening.

By default in the email it tells the other users that the suer who created the ticket has shared it with them but they have not.

Any help greatly appreciated.

Cheers

Phil

3 answers

1 accepted

Hi Phillip,

I have a similar issue. Can you try this to verify if it is the same thing:

  • go to Project Settings > Request Types and click "Edit Fields" for the request type you are having problems with.
  • now click the link called "View this request form" somewhere near the top right of the page.
  • that should bring up the request form, with a "Raise this request on behalf of" box. 
  • In there, pick one of your 10 customer users to see what the request form looks like for them

When you do this, does a "Share with..." option appear towards the bottom of your request form? Something like:

share-with-org.jpg

If you get your users to change this to to "Private request", before they raise, then the issue won't be shared, but they have to remember to do it:

private.jpg

I'm not sure why JIRA defaults to "Share with..."  at this point, rather than "Private request", but I'm looking into it to see if it can be changed. I'll comment here if I find anything.

Please let me know if you find a solution.

Hope this helps a bit.

Sam

Ah. Found the answer in different questions:

To disable the notifications, you can go to Project Settings > Customer notifications and disable the Organization added email rule.

Sam

Like Jeroen Keesom likes this

Hi Sam,

Thanks so much for getting back to me - I really appreciate it.

I have tested the second solution above and it seems to be working great now.

Thanks again :smile:

Cheers

Phil

Brillant just what I was looking for, took a few moments to find the enable checkbox in the lower right corner though.

Hi, both links above are not available now, I have seen the change request is still under development.  

After reading this thread the solutions to the problem are:

- Wait for the fix

- That the user remembers to set private the ticket created from service desk portal

- disable organization notification

 

But is there a way to force "private request" as default instead of share with organization via configuration?

 

Thank you.

Like # people like this

Sameproblem here with Jira cloud, no way to remove the "Share with" mandatory field.

Let's hope for a quick fix!!

Thanks

P.

Like David Harkins likes this

This thread was helpful to me to be able to turn off the organisation auto notification (thank you), but I'm wondering if there was any progress in JIRA changing the default setting.  I realise it is still the default, but is there any way to change this, or is it still the same?

For Jira Service Desk Server this has been adjusted now (from version 4.7.0); issue: https://jira.atlassian.com/browse/JSDSERVER-4382. By default new issues are shared as a private issue. Not for Cloud yet.

Like Will Seay likes this

I had this issue and was able to resolve. Check these 2 things:

Disable "sd.notification.default.rule.request.organisation.added.name"

under Automation settings in your project.

Ensure that "Organization added" is also disabled, under Customer Notifications.

Matthew, can you confirm which version of JSD you're using?  I'm using Cloud, and I don't see the rule you mentioned under Automation settings. 

Also, does disabling this rule impact the customer's view when they submit a request?  Or does it still appear to them that they're sharing with the rest of their organization?

I couldnt found this either. 
I have no option for disable in automation settings

Where is this line?

sd.notification.default.rule.request.organisation.added.name

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you