Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,588
Community Members
 
Community Events
165
Community Groups

JIRA Admin - JIRA Status Sort - can't reorder statuses to pull last one up the list

Using JIRA Cloud I am in Administration > Issues > Statuses. I'm re-ordering the statuses. 

When I try to reorganize the items at the bottom of the list, they simply don't move. When I try to swap the last two, neither moves. The one at the bottom of the list is in the "In Progress" category. I'm trying to more it up the list so it will sort before the ones in the "Done" category.

The third one from the bottom also won't move down or up.

If I go to the sixth one from the bottom, I can push it down at least three spots, and push it back up. I don't want to push it any farther down for fear it could get stuck in one of the last three spots.

Has anybody else seen a problem like this? 

4 answers

2 accepted

0 votes
Answer accepted

I'm having the same problem, and it's quite frustrating. Changing browsers didn't resolve the issue. 

0 votes
Answer accepted

Hi Trudy,

Welcome to the community and thanks for reaching out, that is weird behavior.

I just tested this out on my cloud site and I am not seeing the same behavior so it does not look like platform bug, but there could be an incompatibility issue in the browser.  I did my test on latest chrome Version 78.0.3904.70 (Official Build) (64-bit), are you using a different browser or browser version by chance?

Also, I would suggest running through the recommended checks in our "Browser Troubleshooting Guide" , in the "Indispensable tests" section to rule out a few possibilities like browser extensions and caching that are common causes of one off behavior issues.   Then I would recomend launching the browsers development tools console to see if any errors are noted in the console logs that could help narrow down the issue.

Let me know what you find

Regards,
Earl

Thank you for the suggestions, Earl.

I am using Chrome v77.0. I had the issue in Chrome originally last Friday. Since then I had exited and restarted Chrome, but the issue was still occurring yesterday. Yesterday I had replicated the issue in Safari also. Since yesterday I have exited Chrome and restarted it again (I do that daily).

Just now I pulled the JIRA tab from my multi-tab Chrome window into its own window, and opened the Developer Tools to check for errors. Subsequently, the item moved this time, so the problem is now not reproducing. I'll make note of your suggestions for next time, though.

Regards,

Trudy Claspill

Like Earl McCutcheon likes this

I was totally perplexed on this issue and after I read this, I upgraded my browser and refreshed several times and was finally successful.  Thanks so much!

Like Earl McCutcheon likes this

I'm having the same problem. I've tried in both Chrome and Edge - both have the same problem (and I've tried Chrome Incognito as well; Edge is a fresh install and I've not put any plugins on it and had no cookies or cache for that page until I went there the first time).

 

In my case, it's two recently added statuses at the bottom of the list that are the problem. Sorting involving any other statuses works perfectly.

 

I might try again later, in case there's some weird behaviour with new statuses.

Like Joe Lagana-Jackson likes this

I'm experiencing the same thing, but randomly - either statuses at the bottom or in the middle. Doesn't seem to be rhyme or reason why it won't work in certain instances.

I am having the same issue of not being able to reorder the statuses with the Order Arrows on the Issues --> Statuses screen.  I have tried the latest version of Chrome, Edge, Chrome Incognito and even tried on a completely different computer. 

After following the recommendation listed above I tried Safari and still have the same issue.

At first I was able to move a couple of the Statuses a couple of spots but now it no longer seems to be working.

Any help/advice would be greatly appreciated.

Like Julia Anderson likes this

I would like to add that I ran into this issue today and need to move around some statuses. 

It seems like "randomly" I was able to move a status up 2 overall spots, but I must have clicked the action 50+ times.

I tried Chrome 87, Chrome Canary 89, Safari 14.0.2 - all failed to behave as expected

Like Jose Manuel Fernandez likes this

I was able to finally move one of my statuses to the correct position and it was quite the ordeal. In my attempts at using different browsers I noticed that I could move it 1 place if I went into a new browser.

So, I ended up using Chrome Canary to move the status 1 line at a time. After I moved it 1 time I was unable to move it again until I cleared ALL browser data. I then logged into my Jira again and was able to move 1 place. I did this action about 7 times before I was able to just start moving the status with no issues. 

Facts: we have 65 statuses in our Jira, The status I was trying to move was called "Test Review" and is of the "To Do" category. When I started the status was in the 63rd or 64th position. I don't recall exactly when the behavior started working appropriately, but it was when my status was in between the 53rd and 61st statuses.

I hope that this information helps Atlassian track down this issue 

Like Julia Anderson likes this

I'm facing a similar issue. I'll try the steps you mentioned. The status that I can't move past is "In Review". 

Hopefully this can be resolved.

@Matthew CHALLENGER - maybe you can try the complicated method that I did and get it to a working state.

I am facing the same issue. I was able to make it move by opening a new FF Browswer but then it only worked once.  So frustrating, we have like 50 statues across multiple projects.

Well this thread doesn't seem 'solved' to me... having the same issues... some statuses move some don't some move a few times then won't move any more.  Very random and very frustrating!

Like # people like this

@Marty Wright 

There can be a difference between a problem being solved and an answer being accepted. This thread is not purporting to address the root cause of the problem. I accepted the answer offered because, during the course of following the suggestions, the problem did not recur.

Like # people like this

Thank you @Trudy Claspill , sorry that was poor wording on my part and certainly not directed at you - more a frustration that there seems to be a larger technical issue underlying this and I can't seem to track down any solution yet.  I've logged a ticket on this and will keep digging and post any updates if/when I can get a good solution.

Like # people like this

Drag and drop would work best for reordering. They have this UI pattern in other parts of the app. Why does confluence keep showing me that stupid survey when CRAP like this exists all over the app?

Like Julia Anderson likes this

My suspicion is that it's not related to the browser, what it is is that the backend of Jira (Cloud) is _really very slow_ to actually process the reordering, and seems to get slower and slower in any given session. Beyond a point it starts ignoring the request to perform a reordering operation.

If I take it reasonably slow and only do one re-order request every coupla minutes, I'm making some progress (same browser). I also switch between different statuses so I'm not trying to do too much with one status at a time. This seems to help.

The issue seems to be that the response to the requests are coming back as 200-OKs, whereas a `429 Too Many Requests` might be more appropriate, and for the UI to block for a while.

It *seems* like changing browsers and faffing around with upgrades helps, but I think this is only because that all takes time to do, and in the mean time Jira's had enough time to process [whatever], and a start accepting more requests.

You are absolutely correct. The fact Atlassian attempted to blame the issue on a browser is ridiculous. 

The BE is just crap at updating this. Also, if you could move statuses around by a rank, not sorting one at a time with an arrow slider, like done with other items it would solve the issue quickly and easily (for user).

I had an intransigent status, stubbornly staying put when clicking the up/down arrows. On a whim I changed it's Status Category and tried moving. Success! Move again - nope back to stubborn. So I tried alternating between changing status category and moving it. Success!

Obviously not a root cause solution, but give it a go if you are facing the same problem. Just remember to set your status category back to original value.

Can you describe how you change the status resolution? I don't see how to change this from the Issue Attributes, Statuses page.  That is where I am having trouble reordering. The relationship between that page and Issue Attributes, Resolutions page is unclear.  Thanks.

Shoot my bad! I should have written "Status Category" not "Resolution". Amended.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you