JIRA - Activity Streams not working?

HI All,

Before we used JIRA 5.x as a JIRA System Administrators we saw all activity on all project (on Activity Streams). Now after upgrade we see only activity from the specific projects (not all). Even if there was an activity on some of them we do not see any entries..We see only text: "No activity was found."

Is this a normal behavior? If yes, can somebody explain why I do not see activity even if I will add new issue to the project (or I am participating in it)?

Thanks,

Mirek

7 answers

1 accepted

1 vote
David Currie Atlassian Team Aug 02, 2012

This could be caused by your JIRA System Administrators missing the JIRA Users Global Permissions. As in those docs:

(warning) This does not include the JIRA Users permission. A user with JIRA System Administrators will be able to log in to JIRA without the JIRA Users permission, but may not be able to perform all regular user functions (e.g. edit their profile) unless they also belong to a group that has the JIRA Users permission.

Can you please check if your user has the JIRA Users permission, and if not try adding it then viewing the Activity Stream again?

Otherwise it could also be caused by a misconfiguration with your Base URL or reverse-proxy, if you're using one. Please double check that the base URL is the exact URL you're using the access the instance, as in Configuring JIRA Options. The JIRA dashboard gadgets proxy themselves, so if there's any issues with a reverse-proxy and JIRA can't access itself, an error can be generated. If you have any invalid characters in that URL, such as a % or _ it will also generate errors.

You could also try clearing your browser cache, or use private/incognito mode on your browser to see if there's any issues with browser cache.

Are there any Stack Traces in your atlassian-jira.log file when loading the Activity Stream? If so, please let us know as they may indicate some other problems.

Hi David,

Thank you very much for reply.. I have checked your suggestions..they are very helpful!

This is reproduced by also other users, not only system administrators and all of them have JIRA Users permission.. That is not the case..

Base URL is the same as users use to login.. It do not contain any % or _ it is only https://ourbaseurl/jira .. I think this not also the case..

Browser cache was cleared.. I have also used incognito mode and there was still no activity..

I have checked also the log files.. I tried to add, refresh, edit but this did not create any Stack Trace or errors in the log files..

Hi David,

After raising a ticket to Atlassian support we noticed that the problem is related not with the base URL but with the JIRA project keys!

Everything was working fine before upgrading to JIRA 5.0.. After that all activity on project that contain underscore "_" is empty. So basically you were right that this could be a problem with the URL.

There was a BUG created by Atlassian Support, some users were voting on it, but now it seems like it is Resolved and Tracked Elsewhere..

https://jira.atlassian.com/browse/JRA-27967

If this "Elsewhere" is the below ticket:

https://ecosystem.atlassian.net/browse/STRM-2095

Then it is awaiting development in:

https://jira.atlassian.com/browse/JRA-30104

The sad thing is that Minor priority.. Lets hope it will be fixed soon because it is affecting a lot of projects! If someone can please vote on those issues.

Thank you for your help!

Regards,

Mirek

Hello,

I had the exact same problem.

Suddenly, the Activity Stream Gadget on the dashboard didn't show any activity, only the text: "No activity was found." was presented.

when I looked at a some random Issue/Project/User - There was an activity stream. only the dashboard gadget didn't show anything.

I'll make a long story short: I found that there was a single issue with no text in the Summary field, which is a mandatory field. After editing that issue (sub-task to be percised) and adding it some text in the summary, everything came back to normal again, and activity stream worked just fine.

Hope it can help you.

I am having the same problem - I whittled down the issue types until I found the issue type causing the problem, but I can't find the issue. Any hints? In the logs it's just a stacktrace about "java.util.NoSuchElementException".

Greenhopper Board created for a Project that was later deleted also leads to "No activity was found." in
Activity Stream Gadget. To resolve - delete an obsolete Board.

Deleting an old Agile board also worked for us, under Jira 6.3...

While we have been using Jira v4.4 we evaluated the use of Jira 5.1, but one thing we realised, is that the activity stream was not completely restored into the test Installation, i.e. it was there in Jira 4.4, but not in all projects in Jira 5.1 after the restore.

I have not idea, why this happened and also the Support could not answer it.

This works sporadically on our hosted installation.

At times it returns the correct results but mostly it brings back "No activity was found" however I know there is activity.


Amy ideas?

Hi Folks,

My activity stream is not showing anything for cloud version for an specific project. Even if I configure the gadget for getting that specific project, it doesn't show anything up.

Any idea?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira

Mission-critical battery manufacturer fulfills FAA software requirements with Commit Policy Plugin

EaglePicher Technologies is a leading manufacturer of battery systems for diverse industries like defense, aviation, space or medical. As they operate in highly regulated industries, keeping a clear ...

118 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you