It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issue with DKIM/SPF setup - JIRA Cloud

I am running into an issue when following the steps from: 

(https://confluence.atlassian.com/adminjiracloud/configuring-jira-cloud-to-send-emails-on-behalf-of-your-domain-900996548.html)

(Using NetworkSolutions), I added the two DKIM records below: 

NS1.png

FYI: another entry already existed from a previous administrator

NS4.png

But I also updated SPF record:

NS2.png

And still get this error message when checking verification:

NS3.png

 

Any help would be appreciated. Pretty much stuck at this point on what to do. 

2 answers

1 accepted

0 votes
Answer accepted

Hi @Jules_Babayemi ,

I can see that this issue has already been solved in a support ticket. However, I am pasting the solution in here so that can be useful to other users that might be facing the same issue:

[...]  you need to be both site and Org admin to be able to edit the project email address, otherwise, that error will be displayed, even the verification being valid at https://domain-check.atlassian.com/. You can read more about this here.

[...]

 

Cheers,
Dario

Thanks, this worked for me. 

Like Dario_Bonotto likes this

The read more link doesnt work. Has the page moved?

I believe the url is slightly different. Try the below link instead and let us know if it works:

Like Ian_Howard likes this

Thanks Dario

I had found that but it didnt help. I still get a DNS error on the SPF record.

 

Is there anything different you need to enter in Route 53?

@Ian_Howard  

Can you confirm you claimed and verified it.asxxxxxxxxy.net ?

If that's the case, by using nslookup as well as https://mxtoolbox.com/ the problem here seems to be that you are using a deprecated record type (99) instead of using a TXT record:

No SPF records found as TXT. (Record type 99 (SPF) has been deprecated)

 

For more details on this, please see also:

 

Finally, please notice that adding a reply to a 6+ months old thread that is already marked as solved is decreasing the chances to get an answer. For the future, you may want to create a new thread instead. 

 

Cheers,
Dario 

Thanks Dario.

I have added the SPF strong into the TXT record with the Validation string as I can't create two txt records the same. Would that work?

 

The domain is claimed and I get the nice green verified text. 

 

Also, noted on the 6+ months old ;)

Hi @Ian_Howard ,

According to the Amazon Route 53 - Supported DNS Record Types - TXT Record Type documentation you should be able to achieve the same result of having multiple TXT records by putting each value on a new line:

Example for the Amazon Route 53 console

Put each value on a separate line:

"This string includes \"quotation marks\"."
"The last character in this string is an accented e specified in octal format: \351"
"v=spf1 ip4:192.168.0.1/16 -all"

 

Example for the Route 53 API

Put each value in a separate Value element:

<Value>"This string includes \"quotation marks\"."</Value>
<Value>"The last character in this string is an accented e specified in octal format: \351"</Value>
<Value>"v=spf1 ip4:192.168.0.1/16 -all"</Value>

 

Please review that documentation page ( Amazon Route 53 - Supported DNS Record Types - TXT Record Type ),  add the Atlassian verification token and the SPF record on separate lines and let me know once done so that I can try to test it (you can do that as well by using nslookup or dig or other similar tools).

 

Cheers,
Dario

Thanks a lot Dario.

 

I managed to resolve this earlier thanks to your previous messages. We're all up and running now.

Like Dario_Bonotto likes this

You are very welcome @Ian_Howard , I am happy I was able to help.

Have a nice day!

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you