Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issue searching some custom field (using Default Text Renderer) on Jira Cloud Edited

When utilizing Jira Cloud today unable to use advanced search to search for a Criteria (aka custom field) called "Found in Version".  This has worked perfectly fine just a few days ago when we may have last tried it. What's changed?

Note some custom fields work but not clear why this does not work or a couple of others

There may be a Jira cloud update and will try again tomorrow to see if the problem is resolved. 

Anyone else seeing this issue?

1 answer

0 votes

What type of field is this "Found in version"?  

Custom fields can be of many types - text, dates, numbers, various types of selection lists, and even Jira versions.  You've said "default text renderer", but I'd like to be certain of the type before we start debugging.

Also, what exactly "does not work"?  Cannot type the name in JQL and have it auto-fill?  Field not showing in basic select?  Can name field and run a search, but get unexpected results?  etc.

Response from Jira Support Team: They have acknowledge the issue.

It is an important fact that Classic Project and next-gen project do not share the same custom fields. Even they have the same name they aren't the same field. This is the root cause of the problem: Jira tries to find the custom field "Found in Version" but it wrongly assumes the customfield is of one next-gen project instead of the one of the classic project.

That's why the basic search works for the next-gen and not for Jira Classic.

Assumption: your Jira Cloud has a mix of Classic and next-gen Jira projects.

Steps to reproduce:
1. Go to Advance Query
2. Pick a Project (Classic Jira Project)
3. Attempt to added Criteria and attempt to select a custom field such as Found in Version or Fixed in Version that are common fields in both Classic and next-gen Jira projects
4. See that both custom fields are greyed out and cannot be selected.

Current workaround (not great):
Filter on the custom field first and then select the Jira project. This is not how users would normally attempt to narrow a query, most users will select the project first then narrow their search.

See https://jira.atlassian.com/browse/JRACLOUD-75453 for more details and related issues as well. 
This issue is not getting enough attention please vote up. 
Thanks.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you