It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Install Issues on Windows 2016 Server.

Hi,

I have a completely new win 2016 server install running MSSQL 2016 dedicated to Jira Service Desk. Version 4.6.0 Windows.

Specs as follows:

Server version: Apache Tomcat/8.5.42
OS Name: Windows Server 2016
OS Version: 10.0
Architecture: amd64
Java Home: C:\PROGRA~1\ATLASS~1\Jira\jre
JVM Version: 1.8.0_202-b08
JVM Vendor: Oracle Corporation

Using CATALINA_BASE: "C:\Program Files\Atlassian\Jira"
Using CATALINA_HOME: "C:\Program Files\Atlassian\Jira"
Using CATALINA_TMPDIR: "C:\Program Files\Atlassian\Jira\temp"
Using JRE_HOME: "C:\Program Files\Atlassian\Jira\jre\"
Using CLASSPATH: "C:\Program Files\Atlassian\Jira\bin\bootstrap.jar;C:\Program Files\Atlassian\Jira\bin\tomcat-juli.jar"

Created and have tested DB connection - no issues. Whenever I then proceed to then connect after MSSQL Connect I get white screen.  

Appears all is running.

Following issues appearing in atlassian-jira-gc-2020-01-06 LOGS.

[GC (Allocation Failure) [PSYoungGen: 194560K->11833K(217088K)] 249833K->67114K(489472K), 0.1075420 secs] [Times: user=0.56 sys=0.02, real=0.11 secs]
2020-01-06T15:21:40.269+1100: 175.316: [GC (Allocation Failure) [PSYoungGen: 206393K->7384K(240128K)] 261674K->62673K(512512K), 0.0172401 secs] [Times: user=0.03 sys=0.00, real=0.02 secs]
2020-01-06T15:21:41.757+1100: 176.802: [GC (Allocation Failure) [PSYoungGen: 230616K->6610K(244224K)] 285905K->61907K(516608K), 0.0238754 secs] [Times: user=0.09 sys=0.00, real=0.02 secs]
2020-01-06T15:21:43.708+1100: 178.754: [GC (Allocation Failure) [PSYoungGen: 229842K->7203K(268288K)] 285139K->62508K(540672K), 0.0238743 secs] [Times: user=0.11 sys=0.00, real=0.02 secs]
2020-01-06T15:42:00.418+1100: 1395.404: [GC (Allocation Failure) [PSYoungGen: 258595K->19942K(271360K)] 313900K->77896K(543744K), 0.0316216 secs] [Times: user=0.23 sys=0.02, real=0.03 secs]

 

Not sure what is the best way to troubleshoot all this as Java is certainly not my forte.

Any assistance greatly appreciated.

Thanks

 

1 answer

0 votes
Bryan Bojorque Community Leader Jan 06, 2020

Hi @Peter Boyle ,

Did you try to increase the Server's memory and restarted the application?

After changing the Physical memory you can adjust the JVM allocation here

https://confluence.atlassian.com/adminjiraserver073/increasing-jira-application-memory-861253796.html

 

It is important that the JVM allocation will not exceed the physical memory.

Hi Bryan,

Thank you for your comments. I did make these changes however I could not get it running. Still not sure as to why it was so difficult.

That said I had tried to install on Unbuntu 19.04 LTS without luck as well which is why I then tried Windows.

I ended up installing everything on Centos 7 without issue on first install on VMWare.

Working really well now so thank you for your input.

Like Adrian_Stephen likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you