Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,360,949
Community Members
 
Community Events
168
Community Groups

I am unable to perform a bulk update even though I have all the permissions

I have site admin rights and individual project level permissions but I am unable to perform a bulk update

5 answers

Was this ever resolved? I am now having the same issue on projects that have been set up within the last month. We are just at the stage of moving tickets over to the new projects and of a sudden our users (one even set to site-admin) not can't bulk edit the Sprint Field.

1 vote
Suren Raj Atlassian Team Apr 09, 2018

Hi, Jenny.

 

Can we know what type of update you trying to perform?

 

At the same time, can you check global permission page and see if you or the group you are in have Make bulk changes permission?

 

 

Cheers

I am in every group we have and I am a site admin

 

I am trying to bulk resolve a group of issues that have been "closed" but I just recently added the "resolve" set to them

Suren Raj Atlassian Team Apr 09, 2018

Hi, Jenny.


Can we know which project you trying to perform the bulk update? We need to check if the resolve issue permission was given to you or the group you are in.

Its actually for all the projects.  They all had closed issues that needed to be resolved

I chose one project and added myself to all permissions and rechecked global permissions- all look fine .  Please see the screenshot of the error I get...Screen Shot 2018-04-10 at 8.43.24 PM.png

You might have permission to transition some of the issues, but the bulk-edit needs you to be able to transition all of them.

Your admin and global permissions are not project permissions, you'll need to identify which projects you do not have permissions to. 

Try taking your query for the bulk edit and running it with a "and project in (xxx, yyy, zzz)" clause added.  For each project the main query includes, add the project to the clause and then check you can transition one of the issues returned.

As I stated, I did pick just one project and tried it- didnt work

Im aware that global permissions and project permissions are different and I have done an audit on both

Then the permissions in the project are against you.

Are you sure you have transition issue, and there are transitions out of all the selected status, and no conditions, and no workflow properties?

The workflow cant be it because Im able to do it on an individual level, right?

 

I added myself to every permission at the projuect level, including ones that have nothing to do with issues (ie- tracking time)

is it possible to do a screen share to troubleshoot this?

You're right, if you can transition an issue from the issue view, then run a search for it and try bulk-edit on just that one issue, and it does not offer the transition rights, then there's something broken.

The problem for me is that I've only once been able to get Jira to do that.  I can either transition that one issue via view, board and bulk-edit, or I can't at all (assuming the same user is in use - I've had some really interesting ones where users look identical, but three's some obscure setting that blocks one and not the other)

The exception was when I had a condition on a transition that I should have been able to pass.  The code for it was broken - it worked on issue view, but crashed on bulk-edit (which effectively returns "no, this user can't transition this").

That is a pretty obscure error though, and it was my fault (my code in the condition).  It does make me think we should take a look at the logs - ideally, have a terminal and a browser open, run your search as normal, then start tailing the log as you select "bulk edit" and go through the process.

I have the same problem, I'm site administrator but I can't change task assignee.   

Is it possible to change the permission in bulk in all project?

Bulk-Operation-Jira.png

No, you have to edit each permission scheme individually.  Or read them and change your account so it matches the permission you need.

@Tomasz Kubera were you able to solve this issue? I have the same problem and I cannot find any relevant workflow property for that. How else can be a custom field disabled for editing on a certain workflow step?

@Małgorzata Rohnka unfortunately I couldn't get around this problem. 

Thanks for answering me. I will start a new thread for that.

@Tomasz Kubera I solved my issue, it was a bug with properties, you can check here if interested

Cannot edit fields by bulk (atlassian.com)

Waiting for solution...

I suspect the issue that was blocking the changes was tracked down and fixed.

Probably by gradually trying sections of the bulk-edit, and seeing which ones failed, then narrowing down more within each section.

I also closed an individual issue to make sure it wasnt that.  

Suggest an answer

Log in or Sign up to answer