Hyperlink in Custom Text field

Julia December 8, 2018

Hi - I am trying to render a hyperlink in a Custom Text field that I created.

I am reading online that enclosing the site in [ ] is the solution, but that only seems to work for the Description and Comment fields which are in WikiMarkup.

How can I change my Custom Text field to support WikiMarkup?

Thanks! 

2 answers

1 accepted

5 votes
Answer accepted
Alexey Matveev
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
December 9, 2018

Hello,

Go to Project Settings -> Field configurations. Find your custom field and set the Wiki Style renderer for your field.

Julia December 9, 2018

Thanks for the response. I don't see a Field Configurations area (I have full admin credentials). The only options I see for some type of field administration is when managing the Issue Types. You can create fields there but there doesn't seem to be anything fancy for configuring them beyond the basic field type (see attached).

Am I looking at something wrong?

Pic 1 - Project Settings

Pic 1.jpg

Pic 2 - Issue Type Management. Goal is to get the Ticket URL to support hyperlink.

Pic 2.jpg

Like Estelle Decanis likes this
Alexey Matveev
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
December 9, 2018

You have a next-gen project. It is not supported there. You would need to use a classic project, if you want this feature.

Julia December 9, 2018

Got it. Thanks for the help.

Alexey Matveev
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
December 9, 2018

You are most welcome! If my answer helped you, kindly accept my answer.

6 votes
Pavel Bryukhanov July 29, 2019

Despite this is marked as "Solved", I spent quite a few hours trying to understand how to fix this. 

You need to make sure that your custom text field is set to Wiki Render. 

Here is 5 minute video which I have created on how to do this. 

https://youtu.be/QCNHPy88iKA

I hope it helps. 

Karen Justo
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 6, 2019

It helped us! Thank you :) 

Aaron
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 6, 2024

Does this take time to kick in? I have it set to Wiki Renderer, but anything I try still comes through as plain text. 

Suggest an answer

Log in or Sign up to answer