It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How can you disable permission to change who the 'Reporter' field is?

Hello,

 

How can you disable permission to change who the 'Reporter' field is?

 

Also is there a way to track or see who the Reporter was previously if I can't restrict people from changing the Reporter?

3 answers

HI,

      If you want to restrict the users to not to change the reporter update the permissions scheme, there is a permission called "Modify reporter" update it accordingly(Give permissions to the one that can modify). 

 

    If you want to see the previous reporter, you can always use History tab on issue to check who modified and what was changed.

 

Thanks,

Ravi 

Thanks for your help Ravi,

 

Ive removed all groups except the 'Administrators' group from it but the user is still able to edit the Reporter field.

 

As you can Jay isn't part of the Administrator group. What am I missing that he is still able to change the Reporter field?

 

Snip20191206_30.png

 

Snip20191206_29.png

Hi,

as said by Ravi, you'll need to set the Modify reporter permission.

This is however a project permission, so you'll have to make changes in the permission schemes .

Each project has a permission scheme which is probably shared over multiple projects.

Please also have a look at project roles , you'll benefit greatly from it when managing your instance in the long run.

Hi Johan,

 

I did remove all users from the 'Modify Reporter' from the default permissions scheme except the administrators group. 

 

I would have thought that removing a user/group from this wouldn't allow users to be able to change the reporter on the tickets which is what I want to do.

 

Unless I am missing something?

Hi,

you'll have to verify which permission scheme is used in the projects where you encounter non admins modifying the reporter.

The default permission scheme might not be used in those projects.

I've only got 1 permission scheme. I followed the instructions for this to make sure I've assigned the correct permission scheme to to the correct Project. 

Snip20191211_56.png

But after step 2 I can't seem to see the permissions section or anything on the lower right like the instructions say. 

 

Snip20191211_57.png

Hi,

you'll have to select Project settings in the sidebar where you'll find a section Permissions.

Very useful is always the Summary.

It also seems to be a Jira Service Desk project which will have created its own separate permission scheme.

Yeah I've tried that.

 

I've gone through all the menus on my current project and I don't see a separate permissions menu other than the one for the whole JIRA account

 

I noticed when I used Permission helper there is a DEMO: Simplified Permission Scheme? Where is that located? I don't see it under my list of Permissions Schemes

 

Snip20191212_60.pngSnip20191212_61.png

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you