Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Finding user names to bulk upload issues via CSV

My project requires a product owner field to be populated in order to create tasks via bulk CSV upload. We have just transitioned to the new cloud version of jira. 

Previously, to find someone's user name I would search for issues assigned to them and then switch from basic to JQL search and copy their name which would usually be a combination of letters their first and last name. EG John Smith would be "josmit"

Now I am trying to bulk upload in the new version of Jira and the old user names are no longer being recognized. When I search for the user and switch to JQL in new jira, the names appear like this: "john.smith" I tried to copy this version also and it wasn't recognised in the bulk upload. I also tried to click on the user name to see their profile to find their user name and that did nothing. 

So my question is... how do I find the correct format for individual user names in cloud jira in order to assign them as the product owner when bulk uploading from a csv file? 

Thanks in advance for answering :) 

2 answers

0 votes
Ivan Lima
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Oct 09, 2023

Try using the user's accountId. It will work. See for more details on how to find the accountId. Also, try using the CSV bulk import with a smaller subset and make sure that you and the users in the CSV have the proper permissions.

Hi Dominique! Can you try giving the full email address instead of the username? Last week I had the same problem when trying to massively import issues from a previous instance and I solved it by changing the username in the user fields (system as reporter or assignee and also custom fields of the user selector type) to the email address electronic.



Thank you for the suggestion, unfortunately I just tried it and this didn't work either.

Strange! make you sure that those user exist in your instance. If you can provide a screenshot whit log error



Thanks again for your answer. I tried again to upload and just used myself as the product owner for all tasks and got the same error: validation error.pngIf it's relevant I can make myself the product owner of tasks just by editing a single jira. 

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events