Error deploying new standalone war

I'm attempting to upgrade from jira 4.1.2 to 4.4.6. Right now, I just want to run 4.4.6 as a standalone out-of-the-box. However, when I go to the home page, the first thing I get is a NoClassDefFoundError: com/atlassian/jira/web/util/ProductVersionDataBeanProvider.

Like I said, I'm running this straight out of the box. What could be missing? To deploy, I downloaded the war.zip and copied the webapp directory to my Tomcat webapps dir, just as I do with 4.1.2.

Thanks for any input!

1 answer

1 accepted

0 votes
Answer accepted

Hi there,

May I know if you deployed JIRA 4.4.5 WAR to the same Tomcat that were running JIRA 4.1.2? If this is true, then perhaps can you kindly try to clear the Tomcat work directory ($TOMCAT/work), restart the Tomcat and see if it helps?

That was it! Thanks so much!! I used a copy of the original Tomcat dir, but didn't clear out the work directoroy.

Thanks, great to know that the problem is resolved now on your end. :)

Have a pleasant day!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Thursday in Jira

Updates to jira.atlassian.com give you visibility into what's coming in Jira Server and Data Center

Hello, Community! My name is Gosia and I'm a Product Manager on Jira Server and Data Center here at Atlassian. Since 2002 when we launched our public issue tracker, jira.atlass...

324 views 1 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you