Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Disable emails from Automation for JIRA

When an automation succeeds, I receive an email from Automation for JIRA about what was updated in the ticket.  Is there a way to disable this email functionality?

 

Thanks!

2 answers

1 accepted

1 vote
Answer accepted
edwin vasquez Community Leader Dec 17, 2019

Hello David, 

you would need to go into the automation rule and edit it.

automation for Jira emails.png

Hi Edwin,

Thanks for the reply!  Here is what I see when look at the rule:

Rule.JPGI don't see that notifications check box.

 

Thanks,

Dave

Oh wait.  Nevermind.  I was looking at the wrong rule......jesus...

 

Thanks!!!

edwin vasquez Community Leader Dec 17, 2019

Awesome! Glad, we could figure this out. Please mark this as answered if it resolved. your issue. Have a great day!

Boss I'm New Here Jul 26, 2020

@David Anthony I'm seeing the same screen as you were above (transition screen).  How do you get to the Edit Screen?  Thanks.

edwin vasquez Community Leader Jul 27, 2020

@Boss  you have to make sure you have an "Edit issue" action in your automation before you can go into that screen.

@edwin vasquez I added an edit action and still received a notification. 

For some quick background, I'm using automation to transition an issue to the "selected for development" status when an issue is being created.  I have a simple checkbox custom field to trigger this on issue creation.  So I don't really have a need for an edit component in my automation, however, I added one at the end of my automation and unchecked the email notification checkbox in the edit component as discussed above. 

Note: I started to get a failure notification since I wasn't editing any field.  So I had it edit dummy field and stopped getting the failure notifications,

Although, after doing this I still received a notification that the issue had transitioned to a new state.  So I realized that if I were to turn off notifications for issues I'm watching or I'm the reporter of (here /secure/ViewPersonalSettings.jspa#emailpreferences) then I don't get the notification.  However, that is a global setting and will apply to ALL issues rather than just the ones that the automation runs on.  I obviously don't want to set that setting. 

I think I'm getting this "transition" notification b/c I'm not the actor of the issue.  And it doesn't appear there is a way to change that. So I'm thinking I'm stuck, however, it sounds like others have solved this.  So if you have any thoughts I'd really appreciate it.  

0 votes
edwin vasquez Community Leader Dec 19, 2019

Please mark this as answered if it resolved your issue. Have a great day! 🙂

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you