It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Development Panel not displaying even though Source tab is displayed on issue detailed screen. Edited

Hi,

 

I have a problem with my Jira / Bitbucket instances that affects only some projects - for others it works fine. There are two cases :

a) In one project, when commits are made with a Jira issue key in the commit message,

they are displayed in the 'Source' tab of the issue, but not in the development panel

b) In another project, commits with a Jira issue key in the commit message do not appear

anywhere in Jira at all - neither in the Source tab nor in the development panel

For other projects it works fine, that's why my first thought was permissions, but I set it up in the permission scheme that anyone within the project has the 'View Development Tools' permission, and it doesn't help at all.

I also saw this, but using the refresh on project's development tools tab or waiting any amount of time (this has been going on for weeks, I also tried restarting Jira while Bitbucket is on) has not helped either.

Any ideas, of what else I should check?

 

Versions are :

Jira Software Server 7.6.2

Bitbucket Server 5.6.2

 

2 answers

Had this issue...

For many issues under several projects the Development panel was visible, but I was struggling to show the commits for some new projects.

Application links were already there, and working fine.

Added the new project into Fisheye, of course, but still no Development panel.

 

At the end it turned out that until a Review is not created, the Development panel will not show.

So just create a review right out of Fisheye, and the Development panel becomes visible. Even if you immediately delete the review.

0 votes
Gaston Valente Community Leader Mar 07, 2018

Mikolaj,

Check if the development tools setup is correctly configured at the project configuration screen under Development tools.

It should be a link to bitbucket with the view commits permission enabled.

If that's ok we need to keep looking

Hi and thanks for your reply,

The link to Bitbucket looks correct - the URL points to the right application and there are several capabilities listed, including view commits. It generally looks the same way as in the other project where the issue doesn't occur. 

Like Byeong-ook Lee likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you