Customize Service Desk URL

We are trying to setup a friendly URL to http://domain/servicedesk/customer/1 from http://domain following this link - https://confluence.atlassian.com/jirakb/how-to-customize-customer-portal-url-in-jira-service-desk-server-847755218.html\\
However, the instructions doesn't work. The URL does redirect as per the access.log with a bunch of,
[12/Apr/2017:02:29:04 +0000] "GET /servicedesk/customer/portal/1 HTTP/1.1" 301 - 0 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko" "-"

There is no expected POST response from the application when the above path is hit under normal circumstances.
We are aware that Atlassian will not be providing help on redirect setup issues but want to know why a response is not seen to a valid URL that is redirected and if there are any pre-requisites for POST to come up and the page to be seen.

2 answers

This is pretty easy to do in a reverse proxy. Many clients that we work with want their Service Desk to have a dedicated URL that is not the same as their normal JIRA.  It's pretty easy to do this with mod_proxy in Apache and Nginx has similar capability if you prefer that.  I'd leave the Tomcat config alone, since it doesn't survive an upgrade.

Thank you for your response. 

Our Service Desk sits on an AWS instance served by an ELB on the front end. So the ELB forwards port 80 to port 8181 on the backend which the Jira service is listening on. 

To make reverse proxy work, we assume, we would need to proxy all requests from 80 to 8181 on Apache and rewrite helpdesk.it.com to helpdesk.it.com/servicedesk/customer/portal/1? 

Would this work? 

That sounds right.  We typically see jira.domain.com being used for Dev teams and when ITSM gets added, the request is to have helpdesk.domain.com. In this example, the rewrite rule points helpdesk.domain.com to jira.domain.com/servicedesk/customer/portal/1 There's no reason why the hostname needs to be different, though.  Just be sure to check that your rewrite rule doesn't have unintended consequenses before releasing to production.

Works great. I see an error but it is not related to the redirect but an auth mechanism. Thanks for your help!

So just to round of what I did as per Dave's suggestion for others - 

Edited the server.xml file to add this to the connector tag,

proxyName="my.domain.com"
proxyPort="80"
scheme="http"

 

Added a virtual block setting in /etc/httpd/conf.d/servicedesk.conf

 

<VirtualHost *:80>
ServerName my.comain.com

ProxyRequests Off
ProxyVia Off

<Proxy *>
#Require all granted
</Proxy>

ProxyPass / http://localhost:8686/
ProxyPassReverse / http://localhost:8686/


</VirtualHost>

Restart httpd service and it should work. 

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,965 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot