Custom Field that is a single version picker cannot be filtered

When trying to filter by this custom field (for all it's values) I cannot see any tickets, though they are definitely a lot that answer this query's criteria.

When I updated the field (using the edit option) I could suddenly see it by filtering the new value.

Returning it to the old value works - now I see only the one ticket (but I have thousands).

 

re-indexing was made - didn't help. Any thoughts? How can I make JIRA see this field?!

1 answer

0 vote

I'm not sure I understand the problem.  Could you give us the searches you have tried and explain what is wrong with them?  

The JQL is what we need - if you're using simple search, then you can still get the JQL - run the search, get the "broken" result and then click "advanced" and it will display it as JQL for us

project = FSP AND issuetype = Ticket AND affectedVersion = EMPTY

gets no result even though after updating the affectedVersion field, and returning it back to value "no version" - the result shows the updated ticket.

after indexing the updated tickets disappear again.

That has nothing to do with a custom version picker, so I'm still confused. It sounds like the filter is working fine - you get no results when there are no empty affected version issues, and then you get some when you clear it out.

The problem is that there are issues that answer that query. When I fill this field and then remove the value I can see the ticket I updated.

It looks Like I need to manually update the ticket so JIRA can see it.

 

But that's not what you've said - you've described behaviour that works. That's why I am lost. The other question I have is what you mean by "manually update the issue"? Editing the version IS updating the issue. That suggests that you are trying to update the version with something you've scripted, and got wrong...

When editing this field - only edited tickets appear on filter results (until the next indexing process occurs, then the field simply can be filtered).

So how do you put it into a "broken" state? A field change IS an edit, but you say that fixes the problem, so we need to know how you are getting it broken. What process is breaking it? We need to find out what is broken in your edit process because it's not indexing in the way it should.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

77 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you