Copy/paste text between issues doesn't work

Владимир Савостин
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 19, 2021

I try to copy text from one issue description and paste it to another issue description (simple ctrl+c/ctrl+v), but it doesn't work. I also tried to paste it to any text editor, but no results.

59 answers

46 votes
Philipp Kitzberger
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 20, 2021

Having the same issue here on Linux using Chrome since a couple of weeks. And it's only a problem for the new interface though. With the old interface I can still copy/paste without any trouble. Interestingly it's been working with the new interface already but broke only a couple of weeks ago.

Edit: and it's not limited to any specific (editable) field. I cannot copy any text at all.

Philipp Kitzberger
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 15, 2021

I wanna add that I suspect it being related to having opened a JIRA issue link in a new tab. Sometimes it's working again when I refresh that very browser tab. Might be a CORS thing?!

Like # people like this
cesar
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 22, 2021

Same thing here with Ubuntu 21.10 and Chrome. I usually have many tabs open with different issues and when paste is not working, if I refresh the tab, it works again too.

Like # people like this
F. Martins
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 10, 2023

I have the exactly same behaviors on Linux (Debian  12 and Google Chrome v119.0.6045.105) and new Jira. That's so annoying.

Like # people like this
25 votes
Felix Hochgruber
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 3, 2022

Same issue here on Chrome, Ubuntu w/ wayland. This is super frustrating!

Christophe Kamphaus
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 1, 2022

Agreed this is very frustrating and is happening for me as well.

Like # people like this
Thomas Amar
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 26, 2023

I also have that same issue.

17 votes
Viktor Guttmann
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 16, 2021

 I can report this issue as well (Ubunut 20.04, Google Chrome 96)... just to add some extra pressure.

It seems like a custom event handler does something nasty:
Neither  theCTLR+C nor the Context menu/Copy work.

No JS issue/error reported on the browser's console.

Reloading the given page helps a bit, but obviously it's annoying.

Francesco Salvi December 16, 2021

same exact symptoms as mine, and same workaround I'm using (reload)

Like # people like this
Gökhan 'Mete' Ertürk October 25, 2022

@Viktor Guttmann @Francesco Salvi 
I had the exact issue. My workaround was to write a tiny script as a temporary solution to Copy/ctrl+c not working on Jira.

You can find it on github with the name 'fix-jira-ctrl-c-on-linux'.

Disclaimer: Keep in mind that this uses a bad practice to solve the issue, and is not an official solution either. Don't use it if you don't understand what it does and how.

https://github.com/gokhanmeteerturk/fix-jira-ctrl-c-on-linux

15 votes
Francesco Salvi December 16, 2021

this is decreasing my productivity so much, please fix

14 votes
Lior Koskas
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 9, 2022

Same with Ubuntu 20.04 and Chrome 98.0.4758.80.
It's happens even when you are trying to copy/paste in the same issue.

 

27/11/2022 update: It's still happening at Ubuntu 22.04.1 and Chrome Version 107.0.5304.110 (Official Build) (64-bit)  

9 votes
Gerard Lang
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 27, 2022

Is there a fix for this?  Is there even a simple answer?
Why is the most basic of core UI functionality so poorly overlooked and neglected in everything that Atlassian / JIRA do?  Where is the business model in constantly disrupting and disappointing your customers to the point that we just expect this level or amateurism and p-poor attempts at core baseline functionality from Atlassian.   You wont have or deserve much market share with this level of lazy half arsed wilful neglect of core customer functionality and needs.

Francesco Salvi July 27, 2022

👏
as we say in my country
"Severo ma giusto"

not even joking, I just pitched switching software suite to my company just the other day, mostly out of fear that this instance of incompetence is an omen for even worse things to come.
It's not much the fact that the bug it's been there for almost a year, what really adds insult to injury is the total lack of any feedback.

Like # people like this
Gökhan 'Mete' Ertürk October 25, 2022

@Gerard Lang 

You can find an unofficial solution on github. Name of the repo is 'fix-jira-ctrl-c-on-linux'.

Like Tomasz Paździurek likes this
8 votes
Matt August 18, 2022

COME ON ATLASSIAN! TEST YOUR PRODUCTS!

Sometimes refreshing the page allows me to paste for a while - then it stops working again. Copy is also not working properly. Sometimes I can copy then paste into other apps. Sometimes copy doesn't work on Jira pages.

So you have broken paste with custom event handlers or key bindings.

This has been broken for most of 2022.

8 votes
sberton
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 18, 2022

This is still a problem!!!

7 votes
Valentin Baert
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 26, 2022

It happens all the time on every issue. 

Everytime I open an issue I have to refresh the page to make copy/pasting work.

This is so annoying, please fix, it's been around for months already.

6 votes
Rafael Sirotheau
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 3, 2023

The problem still exists today. Using Pop OS 22.04, Chrome.

It seems to happen only when opening a ticket link in new tab (either middle-click or right-click > open in new tab) or when left-clicking ticket link from a tab that already has the problem.

Left-clicking a ticket link from a tab that doesn't have the problem opens the linked ticket also without the problem.

Opening a new blank tab and inserting the link also doesn't causes the issue.


The reload workaround still seems to be the only way to have it working when the issue happens.

m
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 14, 2023

I've only been able to reproduce this problem with middle-click. Both 'right-click > open in new tab' and ctrl-click put me in a good state. I also haven't observed the problem being inherited by child tabs.

But only some pages will cause middle-click to result in a bad state. An example are issue lists in epics.

And you'll know when you're about to have copy/paste problems because the new tab will open in the foreground unexpectedly rather than in the background properly.

To summarize ways to avoid this problem:

- Don't middle click to open links in background tabs. Use ctrl-click instead.
- If you do middle click and the tab opens up in the foreground (instead of properly in the background), this is a sign that Jira will soon give you a bad copy-paste experience, so you better refresh the page.

Like # people like this
5 votes
Caio Mehlem
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 18, 2022

Same issue on Chrome version 103.0.5060.114 (Official Build) (64-bit) on Linux Mint 20

Reloading the page with CTRL + SHIFT + R solves it, until it stops working again... I constantly have to refresh all my pages, which is really driving me crazy.

5 votes
Vilmar Rodrigues Martins
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 30, 2022

Same problem here, with Fedora 35 and Chrome 97

5 votes
Ariel Souza
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 18, 2022

Same is happening with me using Chrome  97.0.4692.71 and Linux Mint 20.3 Cinnamon (5.2.7).

 

Looks like an issue regarding Linux OS because i was using on Windows without issues a few weeks ago.

 

This is really impacting my usability because i forget the copy does not work and have already lost a lot of texts.

 

Thanks.

Steven Malin January 18, 2022

Could be something specific about the chrome build for linux, but I don't think it's a linux issue, otherwise copy/paste would be broken everywhere.  I suspect Jira is using some kind of libraries that the chrome/linux build isn't handling correctly, or Jira isn't handling correctly, that's resulting in this behavior.

Firefox seems to behave fine with Jira if you want to give it a shot.

Like # people like this
Ariel Souza
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 18, 2022

@Steven Malin indeed it is an issue with chrome/linux because i'm copy/paste as usual on other tools and websites.

Thanks, i will take a look into Firefox and Jira

Like liam_tuite likes this
5 votes
Marcelo Fernández
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 22, 2021

I was using Ubuntu 20.04 + Chrome 94.x and it didn't work for me until I've updated today to Chrome version 95.0.4638.54 (official build) (64 bits).

Hope it helps

3 votes
Nathan Phillips
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 26, 2023

Hello all, 

Thank you for your patience. 

This problem has been submitted as a Bug which can be found at the following URL:
https://jira.atlassian.com/browse/JRACLOUD-81000

Other Users have submitted possible Workarounds which can be found in the Comments.

Again, thank you all for your patience and helping to improve Jira Cloud.

Regneel Prahalad
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 31, 2023

Why is this still an issue after 2 years!?? It makes the product unusable. Why is ctrl+c being intercepted? Simply unacceptable.

Like Justin Emrick likes this
3 votes
Wolfgang Fuchs
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 14, 2022

Same here, Ubuntu 22.04, Chrome 108.0.5359.98 (Official Build) (64-bit)

3 votes
Gayan Karunarathna
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 5, 2022

its almost a year after the post, and they haven't even bothered to acknowledge the issue. I'm still seeing this issue with Ubuntu 20.04 and Chrome 101 btw.  

3 votes
Roman Svystun
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 1, 2022

Same issue for me on Manjaro Linux 5.15 with Opera 84

3 votes
Tobias Krönke
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 22, 2021

same here on ubuntu / chrome.

2 votes
Luiz Leite (Kayo) April 28, 2023

Same issue here:
Ubuntu 20.04.6 LTS
Chrome 112.0.5615.165


fix-jira-ctrl-c-on-linux is only for Ctrl+C, someone who knows how to implements some like this for Ctrl+V?

 

...Updated...

So, it's ridiculous, but triggering an alert before opening the new tab with the middle mouse button solved the problem.

I used Chrome Extension JavaScript Injector v1.0.4, with this configuration:Captura de tela de 2023-04-28 18-14-06.png

2 votes
jiri.semmler
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 6, 2022

Hey guys, goood job, good bloody job! It needs some extra effort to develop a product which doesn't support such complicated feature like copy&paste no?

 

I have the same issue on Chrome 96 with Fedora 35

2 votes
Edouard March 31, 2022

Hello,

I frequently have the same problem.

Refreshing the page usually resolve the issue (temporarily).

Tamil Arasan
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 29, 2023

This issue still exists...

2 votes
Roberto
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 20, 2022

Same issue here, using Chome on Linux (Fedora). It works fine on Firefox.

2 votes
Éva Kovács
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 18, 2021

Same here with Ubuntu and Chrome. I noticed it around 2021 September and since then.

Mickael Ange December 10, 2021

Same here and it is still happening today 2021/12/10.

1 vote
Fabian Erni
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 16, 2024

Using Ubuntu 23 and Chrome 123 and still have to reload every detail view of a ticket to use copy&paste in the editor.

Why is Atlassian still ignoring this issue in 2024?

Please report yourself as affected in the bugtracker issue: https://jira.atlassian.com/browse/JRACLOUD-81000

 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events