Cloning a request - reporter is not updated

When I/we clone a request, the reporter field is not updated with a "new" reporter - the person who is cloning the request should become the reporter.

I have looked through everything I can possibly find on this issue and all the answers I find say that if a user DOES NOT have modify reporter permission, then the reporter on the cloned request should become that user/current user. 

This does not work. And I don't think that it has ever worked (at least not for us). I have modify reporter permission. When I clone a request, the reporter is still the same one as on the previous request, but I can change that after the clone request has been created.

When another user, that does not have modify reporter permission,  clones a request the reporter is not changed to current user on the cloned request (new request.

Are we doing something wrong? 

Found this on this site but I don't feel it answers the question.

https://community.atlassian.com/t5/Jira-questions/Clone-does-not-update-reporter/qaq-p/392418

2 answers

1 accepted

Hello again. 

This seems to be the problem (what I wrote above) so no need to look into this further.

Hi Sigridur,

I'm glad you were able to figure that out through your testing and I'm going to accept your answer here in case anyone else has a similar question.

Cheers,

Branden

Hi Sigridur,

I just tested this and if I clone an issue with a user that has Modify Reporter permissions the reporter stays as the original reporter.  If I clone an issue as a user that does not have the Modify Reporter permissions I do get a warning stating the user will be the reporter and it creates the ticket with that person as the new reporter:

CloneIssue.png

  • When you attempt to clone an issue as a user that does not have modify reporter permissions what happens?
  • Does it matter if the user is an admin or not?
  • What version of JIRA are you using?

Cheers,

Branden

Hi Braden.

Thank you for your response.

Ok, looked into users and roles and permissions for a certain project. And then the groups the specific user is a part of.

When I look at Users and roles and look at the groups that are under "Modify reporter", the specific user is in neither one of those groups. However, if I go to permissions, I see that the project role for modify reporter in Permissions is both Administrator and modify reporter roles. And the specific user is in a group that is under the Administrator role  in Users and roles (that group is not under the role modify reporter in Users and roles).

Could this be the problem? The user does not get any notification that she does not have "Modify reporter" permission and the reporter is cloned as well.

I tried this myself, and as you said, as soon as I took away my permission to modify reporter, I got the notification and became the reporter.

Really hope you understand what I am trying to say.. If not, please let me know.

Best regards

Sigga

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

152 views 1 17
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you