Cannot create Service Desk project (feedback-issue-collector was either missing or disabled)

Hi,

I'm running JIRA Core 7.2.6, downloaded the compatible Service Desk .obr 3.2.6 (from here https://marketplace.atlassian.com/plugins/com.atlassian.servicedesk.application/versions), uploaded it and entered an evaluation key for this application (JIRA Core is currently running under a "Developer license").

I wanted to create my first Service Desk project (Basic Service Desk) but it ended up in the following error:
500 - Sorry, we had some technical problems during your last operation.

I can see the project when clicking on the "Service Desk" project category, but I cannot access it. Same error as above.

The log file shows me the following error:

2017-02-10 16:27:06,429 http-nio-8080-exec-12 ERROR anonymous 987x1998x1 g8vxhq <ip> /projects/BSD/welcome-guide [o.a.c.c.C.[.[localhost].[/].[action]] Servlet.service() for servlet action threw exception
java.lang.IllegalStateException: Required plugin module com.atlassian.jira.jira-projects-plugin:feedback-issue-collector was either missing or disabled

I've checked this plugin and it is activated, including all 18 modules of it.

Anyone knows how to solve this issue? Just wanted to evaluate JIRA Service Desk :-/

BTW: Same issue when installing Service Desk not via .obr, but via UI ("Try it for free" function within the "Application" menu).

Thanks & Cheers,
Tom

1 answer

1 accepted

This widget could not be displayed.

OK, solved it:

To disable the "Give feedback" button in the new project navigation back with Jira 6.x, it was suggested to run the following database command as described in the last post of https://answers.atlassian.com/questions/14812165
{code:sql}
insert into pluginstate values ('com.atlassian.jira.jira-projects-plugin:feedback-issue-collector','false');
{code}

This broke the functionality of the Service Desk application.

I've removed this entry and now it works. Strange is, that this command didn't reflect in any way within the "Manage Add-Ons" UI. The plugin and all modules seemed to be activated.

I also have to check if the other two statements will result in any issues using the Service Desk application and if the "Give feedback" function is enabled again after removing the above value from the database, but I can now successfully create a SD project and also access it.

Cheers,
Tom

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 6 hours ago in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

13 views 0 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you