It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot configure Jira Cloud Slack App Edited

Hello all,

I am trying to install Jira Cloud Slack App in my workspace.

Following the guide (https://confluence.atlassian.com/jiracorecloud/jira-cloud-for-slack-950819031.html), after I Authorize the application I got an error (upstream request timeout), but the application gets installed anyway.

The resource which results in timeout is:

https://atlassian-slack-integration.services.atlassian.com/api/slack/oauth?code=212461267617.556152381170.f84b6bcv4d3a3de47d3f8f92a8a1f0d9bb6xxf15d88aa6b922c8bd2e791f5f53&state=d219d62e-xxxx-42f8-xxxx-05a7ae558a6c

 

I can access the configuration and the bot user is created, but I don't get any direct message or in Slackbot with the next steps.

If I DM Jira bot I get

 */jira help* failed with the error "401_client_error"

Also if i invite the user to a channel. Same response to any request: connect, help, etc

Looking for possible answers I found this: https://community.atlassian.com/t5/Marketplace-Apps-questions/Slack-Integration-Jira-Cloud-instance-was-disabled-by/qaq-p/651743, but I have enabled the App.

What could be happening?

Thank you very much,

 

5 answers

2 votes
ryan Atlassian Team Jun 24, 2019

We have seen several reports of `upstream request timeout` from customers that have large enterprise grid Slack workspaces. We've been working with Slack to get to the bottom of these errors but as of yet haven't found a single solution for everyone. Best thing to do if you get an `upstream request timeout` is to contact support so we can dig in deeper. 

One thing you can try meanwhile is:

  1. Uninstall the Jira Cloud for Slack application from Slack.
  2. Wait at least 15m
  3. Install the Jira Cloud for Slack application

The wait step can be important as sometimes the Slack platform processes the install first and then sends the uninstall which leaves the application in a strange state which also can cause 401_client_error issues. 

Please let us know if you continue to have issues.

Same error for us for last 1 month, ditto problem.

0 votes
Daniel Eads Atlassian Team Mar 28, 2019

Hey Beatriz, welcome to the Community!

I realize you encountered this error a few weeks ago but am wondering if you've tried again since then. The Slack connector is still getting a lot of love from our development team and the issue you saw may have cleared itself up. If you're still encountering problems, we can definitely dive in and get the right things connected again!

Cheers,
Daniel | Atlassian Support

Hello, 

We are currently facing the same problem trying to connect Slack with Jira.
We've tried to reconnect the Jira app several times, but that did not help.

*/jira connect* failed with the error "401_client_error" 

Is there a solution to this problem?
Thanks

0 votes

Hello,

I'm currently facing a slightly similar issue. I managed to connect Slack with Jira Cloud. But I just can't connect to a project (I'm Jira Admin)!

When I click on the connect button in slack, nothing happens. 

Anyone knows how to fix that?Capture d’écran 2019-09-12 à 15.41.24.png

Having same issue. Did you discover anything?

Hello, yes!

The permission scheme associated with the project did not grant access to the "atlassian-addons-project-access" Project role (I'm not an experienced Jira admin, so rookie mistake I guess!). I gave this project role all the permissions and it worked fine :) 

we have permissions in the project set with "atlassian-addons-project-access" for everything, but we are still seeing the error failed with the error "401_client_error"

TL I'm New Here Nov 06, 2019

Same here. I've installed JIRA Cloud integration. After that the integration worked for some minutes before the 401_client_error appeared. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

308 views 1 3
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you