Cannot access Jira from public IP in AZURE

Brandon Smith April 20, 2020

We have setup Jira in a virtual machine in Azure due to a legal requirement (we cannot use Jira Cloud because we must store all data in protected environment) and long story short we have verified with Microsoft that all the server settings are correct (allowing HTTP and HTTPs traffic in your network security rules), yet when we try to login to Jira we get a connection refused error. I have re-installed Jira and checked all of the settings, but it does not appear to be working. I believe there is something not working with the connection that is misconfigured on my end, but I have exhausted all options and I am not sure what. I can hit the VM from another VM on the same VNET (they are peered) using the server local DNS name, but any external traffic to the public IP (even when specifying the port in the URL) gets connection refused. I have also disabled the firewall and am seeing the same result. 

 

 

3 answers

1 accepted

1 vote
Answer accepted
Brandon Smith April 20, 2020

I was able to solve the problem, the issue lies with the underlying workings of Azure Government GCC High. You have to enable an exception for port 8080 as well as port 80 and 443 for traffic to flow from the internet. You also need to enable exceptions on the firewall on the server as well. 

0 votes
Nandesh Rasiklal
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 26, 2024

I'm having the same problem here - has anyone found a definitive solution?

0 votes
Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 20, 2020

What are your security group settings?  

Are you able to access jira when you're on the VM?

Brandon Smith April 20, 2020

I am able to access the application just fine when I am either on the server or on the VM connected to the same network....however it is setup as a http://localhost:8080 URL. I have tried changing that url to jira.example.com but that only breaks it further. 

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 20, 2020

Can you post your security group settings for http and https traffic? 

Brandon Smith April 20, 2020

Sure, I've attached the Azure NSG settings...both are allowed on port 80Jira.PNG and 443

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 20, 2020

hrm...try enabling logging on your NSG's to see if it's even getting to them and denied or if the traffic is getting past them.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events