Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't share any filter because the Save button doesn't work in Edit Filter page (except Private)

When I click on Save button in the filter Edit page, nothing happens. Only if I select Private in the Access field it returns a Success message. So I can't share my filters with anyone. 

There is no message or anything. Just doesn't do anything. Checked with a colleague of mine and same happens for him as well.

What can be the problem? Is this a bug? If so how can I workaround it? 

Note that I've looked for extension in the browser (disabled everything). Even tried different browsers. Nothing helped.

Save button doesnt work.png

4 answers

Try to update the search to see if the save button is working then.

If you mean to change the query. then that is working and saved successfully.

Only when I change something in the Access drop down menu it doesn't work.

Go to edit permission button and share with the appropriate team, then that team can see your filter output.

What Permission button? 

If you refer to Access drop down menu ... no option is saved, except Private. 

Have you created any personal custom field?

use simple jql (project=YourProeject) and try to share.

0 votes
Jack Community Leader Dec 19, 2019

@Ciprian , something isn’t adding up here. Can you try edit the filter and change the description only and click Save.

Already did that and it works ok. All edits are saved, except for this Access field. 

I think it might be related to permissions but can't figure what permissions. 

An error message would have been of great help in this case.

Jack Community Leader Dec 19, 2019

thanks. so in looking at your image it seems to show that the filter is "Open" currently. Is this the status when you first open the sharing screen or something different?



When I open it is on Private. I'm trying to set it to Open ... but then the Save is not working. 

Jack Community Leader Dec 19, 2019 • edited

is this on a specific filter or all filters? do you own the filter? Are you an admin? If so please check the following - Jira settings > Global permissions > Share dashboards and filters


Could you please share the JQL?

Are you using JQL on confluence page?

Could you please share same jql with your colleague and ask to check working or not. 

If there is any specific field which are not visible to another users then can use your filter.

It is for all filters. I've created those filters, so yeah, I'm the owner. 

Will check those settings. But I guess I'll need an Admin account. I'm not admin. 

Jack Community Leader Dec 19, 2019

check w/ your admin as I suspect they haven't allowed sharing of filters and dashboards.

Instead of filter you can share JQL with your colleagues.

@Jack seems you nailed it. My group was not part of the Share dashboards and filters

Thanks for the hint.

On the usability side, this just sux. Having an error condition with no error message is useless. 

Jack Community Leader Dec 19, 2019

great! Agree, IMO if you don't have permissions then the share option should be greyed out. Likely there is an open issue for this.

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you