It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't @Mention other users?

I have a fairly new set up.  I am the admin.  I have about 5 other users currently.  For some reason I cannot "@" mention anyone but myself.  Is there a setting somewhere?

12 answers

1 accepted

7 votes
Answer accepted

Apparently they have to be part of the jira-users group, even though I created a custom group and gave it all the JIRA access I wanted.

That doesn't sound right. I can mention people outside JIRA users in the jira I've got here.

Like Atticus Bikos likes this

I agree it's weird, but I triple checked the behavior. I couldn't tag someone, added them to jira-users, could tag them. Did the same for the next user and so on. /shrug

I just quadruple checked it. I typed @a and saw two names. I removed one of them from jira-users and reloaded the page. When I typed @a I only saw the other user.

Ah, hang on. You can only @mention people who have the right to view an issue. So I suspect that you've got jira-users in a role that allows browse, which means removing them from there removes their access, and hence, you can no longer mention them.... So expected symptoms, but a slightly different route than you thought.

Like Jeff_Kavlick likes this

The first one I tried to mention a user on was an issue she created and commented on, so that shouldn't be the problem...

Creating or commenting on an issue does not give you the right to see it. If you remove her from jira-users, she can't see it any more, so you can't mention her until you put her back in.

Like Janne Lankes likes this

How can she comment on an issue she cannot see?

Because when she made the comment, she was in jira-users, so she could see it.

She was never in jira-users until I started troubleshooting why I couldn't mention her. She was not in jira-users when she created the ticket or when she commented.

So she was in another group that gave her access when she created and commented.

Yes, the custom group I mentioned.

Yup, there you go - she can be mentioned when she can see the issue, and can't be mentioned when she can't see it. That's what the docs say.

... She was in "Company Employees" group, which I created to give everyone access. She was NOT in jira-users. She created a ticket. She commented on the ticket. I could NOT @mention her. I added her to jira-users and then I COULD @mention her.

You have to look into the global permissions. Just add a group (i.e. jira-users) to the permission "Browse Users". Then every users in this group can mention other users in comments.

Like # people like this

I can mention as an admin however I gave browse user permission to all of my user groups but some groups still can't mention somebody. Its weird that, in one of these groups, some members can mention somebody, others cannot.

I'm having the same problem here. I've set up a group who have the Browse Users setup correctly. They are part of the scheme with the same level access to others who can use @mention, but they cannot do it. The only difference is that this is a vendor, so I created a separate group for them.  What am I missing?

Hi Nic,

 

my issue is little different. i am the admin for jira and i can "@" mention users also, but in the dropdown when we do this "@" i dont see all the existing users. i can see only other jira admins/ jira-administrators group members.

what might be the issue?

FYI- we are seeing this after we enabled the LDAP yesterdaty

You are probably being limited by the same as above - the missing people are not in groups that allow access to the issues.

i can see them only when they are member of that project but its not happening in our cloud instance which is using SAML. i can mention any name in the comment even if they are not part of that project unlike our on prem instance 

On Cloud they probably are part of the project, they only need read-access, which is the default.

There's no point mentioning people who don't have any access to something - they won't get told they have been named, and it doesn't give any other functions.

understood the point here! but in the cloud instance all users are showing up if i want to comment on any issue and in any project.  Is that cuz of permission differences.?

This worked for us:  You have to look into the global permissions. Just add a group (i.e. jira-users) to the permission "Browse Users". Then every users in this group can mention other users in comments.

Like Adrian_Hayes likes this

Thanks william,

yes, that works.

To be honest I really disapprove of this Global Permissions way of working for mentions... I have several user groups (one for each 3rd party we are dealing with) and several boards (also mostly 1 per 3rd party). I want my third party users that create defects be able to mention me or one of my colleagues. I don't want them to be able to browse all users and user groups because quite frankly they have no business seeing who else we do business with.

Atlassian should implement a finer grained security here: you should be able to browse people in your own usergroup for example...that way I can add our core responders in each of the 3rd party groups and they can mention us, without having access to all our user groups and users... Again, this can be sensitive from a security point of view: some of our 3rd parties are direct competitors of one another and they would not be happy that the other one can see who is working for them on a project with us.

Like # people like this

@Peter Van Geenhoven this is exactly the case and we did not activate the proposed solution for our customers.

Same here! Seems like an easy "next best thing" or quickfix for Atlassian to allow Mentions of users in the same usergroup without requiring Global Permission.

Like # people like this

@Peter Van Geenhoven Thank you for your comments. I have been waiting for this fix for a couple of years now (see my comment from 2017? above) and could never believe that we are the only ones with this problem...

Like Peter Van Geenhoven likes this

Same problem for me!

@Anne-Marie ScheideggerSeems like there are not many people who are terribly concerned with their security....which I find rather careless in this day and age...

Right on @Peter Van Geenhoven - I'm a client in a very similar situation and it drives me crazy I can't at mention my PM, for example, to get her attention on an issue. Now I understand why I don't have that permission and I won't be asking for it.

Like Peter Van Geenhoven likes this

Why can't Atlassian limit the Jira 'user mention' functionality to the issue permission "Assignable User" (from the JIRA project permission scheme) instead of limiting this to a Global Permission? That way a JIRA user can mention any users whom the JIRA user can assign the ticket to.

@Peter Van Geenhoven Your comment is the exact same situation as ours and what is logged here: https://jira.atlassian.com/browse/JRASERVER-7467?focusedCommentId=2274733&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-2274733.

We need to UPVOTE this issue on the link above, so that Atlassian sit up and take notice and implement the easy fix. Well it seems easy enough.

cc @Sean Thompson @Davy_Claes @Math @Thomas_Gottmann @Anne-Marie Scheidegger @Ermal Bizhuta @Nic Brough _Adaptavist_ 

Like Peter Van Geenhoven likes this

@Mark Hawkins Thank you for sending us the link on where to vote (which I have passed on to my team, too) and sorry I never took the time to file or find a corresponding JIRA bug :flushed

Like # people like this

I added my votes, but the deafening silence of Atlassian on this one doesn't promise much good. Seems they are more interested in changing the UX every single week than addressing some basic security issues.

Like Mark Hawkins likes this

I had the same problem and fixed it as followed;

You need to add Brose permissions to the group.

 

Go to: System > Global permissions > Click on dropdown 'Permission' and select 'Browse Users' > Now select the group you want to give this permission in the dropdown next to group > Click on Add.

 

This should give everybody in that group the ability to use @Mentions

I hope this helps!

This is the best answer!

Like # people like this

Fixed my issue, thanks!

Like Fela_Oni likes this

If you want to do this at a project level, goto your Project Administration Page > Permissions > Browse Projects (add role/group/user etc.)

Like # people like this

awesome! Have been struggling for quite a while! Helped!

Thanks a lot, it works!

Perfect answer, Solved the Issue thanks :)

Like Narasimha murthy likes this

Thanks! Straight forward! It solved my issue.

This helped SO much! THANK YOU THANK YOU!! Simple and easy fix. ;)

Just what I needed, thanks! But when I tag someone, they don't receive any notification. Is there a setting for this as well?

Thanks for this... I always forget this when creating a new group!

Bless you Berry. It was driving me crazy

This was a God send, thanks!

If the customer gets this permission, can he also see different projects that are usually not possible for him? 

This solved it for me, thanks! (y)

This should be the accepted answer and first listing on the page.  Thank you for the information!

JIRA 7.3.3 Administration Gear > System > Global Permissions > Add permission:

- Browse users

- The group

Awesome- thank you for this!! This fixed my problem. :D

You're welcome! :)

Thank you this fixed my problem.

What if the group does not appear in the search section?

Even people who don't have permissions to view project can be mentioned via "[~email]". 

On my Jira it actually has to be [~username], which some times is the email, sometimes it is just the part of it before the "@" or the name.

I have Jira 4.1 and double checked my permissions, but when I type in the "@" symbol, I don't get an option to add anyones name. 


All I get is an "@" symbol.

Does anyone know when feature was added?  

How can I highlight user "@" in comment box of any project, I have put jira-user group under Browse Users but its not working , Notification is going but user is not highlight in comments. can anyone please help

 

Thanks

So I've found this page: https://confluence.atlassian.com/jirakb/mentions-and-autocomplete-are-not-working-in-jira-cloud-779160727.html

In it it describes to Add that permission (Browse Users is not a default permission that exists in a default confluence install on the cloud). Scroll to the bottom of the global permissions page, and Add the permission and group. Should work after that.

This is great info thanks!

Now, if I want a customer to have access only to one project, not the others, I assign them to a project role, and associate that project role to a permission scheme, allowing that person to have Browse Projects only for that project. But now I need to enable them to @mention people. Any ideas?

Make sure they have browse users permission.

This has nothing to do with what project they are using or have access to .

I have the same question: It seems that the browse users permission is global, but I would like a customer with access to only one project to only see the people that have access to that project (ie the development team and the users at that customer) but not other customer users that have permission to other customer projects. The goal is to protect the customers privacy and not expose their contacts to other customers of ours. Is there a way to do that?

Like # people like this

I have the same issue, they should be able to tag e.g. a specific group, but don't see other external users.

@Anne-Marie Scheidegger We are encountering the same issue where we would like to mention others when having only a guest account.  Any chance you created/found a work around over the past year?

Hi Aaron, no we haven't found a solution, but I have also not looked into it again. Either we look at the issues every day to see what the latest changes are, or we add at least someone from the team to the watcher list, so we get notified of changes... But I still wish the @mention-list would work per defined group... 

Like Aaron Jones likes this
0 votes
FUN MAN ANDY Community Leader Jan 29, 2019

THIS IS WHY I LOVE COMMUNITY.... 💝

As Jira Admin I always forget these little details (embarrassing... I know!) but have no fear! Community is hear! YEAH :)

And a 4 year old question too. BRILLIANT! 👍🥇

If there are any complete idiots(other than me) looking for how to add an issue link in comments:

Entering issue number in square brackets [ABCD-100] work if the wiki rendering is turned on for that project. But Jira converts it to a link only after you save the comment, not before. Until then you just see it as plain text.

I wasted  two hours checking field configurations and project settings without ever saving the comment. Jira convert the User mention(@username) to link without posting the comment and I assumed the Issue link would also work the same way.

FUN MAN ANDY Community Leader Mar 13, 2019

That's handy to know!

Are you on Server, Data Centre or Cloud?

Like FUN MAN ANDY likes this
FUN MAN ANDY Community Leader Mar 13, 2019

Also good to know! Thanks for sharing @Anand_Sasi - have great day!

What if the users don't auto populate at all? 

FUN MAN ANDY Community Leader Jul 29, 2019

Then there is most likely an issue in the settings of the Jira-Users-group.

I had same problem - could not mention or add watchers.  Our admin added me to jira-developers and it fixed the problem.

Removing the user from the user group and readding the user to the user group worked for us for one user that was not able to mention.

@Andrew Peret that only a suitable option, if all your users are part of the same organisation, and you don't mind your users seeing everyone within your organisation when they try @ mention someone. The issue most people are explaining here, is that they have contractors; agencies; clients; and people not part of their organisation, and for obvious reasons you do not want them to SEE all other users in the platform, when they @ mention a user in a comment or ticket.

Currently JIRA doesn't allow you to restrict @ mention permissions in this way, it's simply either ON or OFF which doesn't work for most people. More explained here in this comment: https://community.atlassian.com/t5/Jira-questions/Can-t-Mention-other-users/qaq-p/5238#M436446

@Mark Hawkins , understood.

Our setup does restrict users more granularly.  Mention permissions is not system wide, but at a group level.

I went through the forums and suggestions on how to resolve our issue, but nothing worked.  

Only one of our users was not able to mention and he had the same permissions as other users that were able to mention.

To resolve, I removed the "broken" user from all groups and re-added that user to the same groups.

It is probably a bug and uncommon edge case.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you