Bug: Users are assigned to issues, but removed on save

Seth Miller April 23, 2024

During the creation of an issue, we are able to view and select an Assignee. Once the issue is saved, the assignee is removed without warning or any sort of message. Why is that? What permissions are needed there? Why is there an error without any sort of messaging?

 

This is a recent change, last few weeks we started to notice the issue on our Cloud deployment.

2 answers

1 accepted

2 votes
Answer accepted
Seth Miller April 23, 2024

The issue was in my workflow! There was a mistake in a workflow that had a Post Function that removed the field. A good place to check!

0 votes
Trudy Claspill
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 23, 2024

Hello @Seth Miller 

If you look at the history information for the issue does it show that the issue is created and then the Assignee field is changed?

It is possible that an Automation Rule is clearing the field after the issue is created. There is a panel in the issue details view, on the right below the More Fields panel. The name of the panel is Automation. If you expand that panel and click the Refresh button in it, do you see entries that indicate an automation rule has executed against the issue?

Seth Miller April 23, 2024

Good thought! No, it only says "Created" in the history. We don't have any automations setup. We're not that fancy :D

Trudy Claspill
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 23, 2024

Are you working with a Company Managed project or a Team Managed project?

Can you confirm that you have not set up a second custom field named Assignee?

Can you have a Jira Administrator go to the Global Automation page to confirm that there are no rule executions listed in the Audit Log tab that are running against the project that contains the issues?

Seth Miller April 23, 2024

Thanks for the continued ideas!

1. Company-Managed
2. No custom "Assignee" field, looking good there
3. There is a basic one about assigning issues to Epics. I disabled it, tried it again, still broken

Seth Miller April 23, 2024

Ah! Atlassian support got back to me:

 

The issue was in my workflow! There was a mistake in a workflow that had a Post Function that removed the field. A good place to check!

Like Trudy Claspill likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
AUG Leaders

Atlassian Community Events