It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Batch email notification not sending email


I have upgraded my instance to JIRA Software 8.1.0 and JIRA Service Desk to 4.1.0 last week and it has been running smoothly.

This morning I activated the Batching Notification Emails feature and from that moment, no further notifications have been sent, either from JIRA or JIRA Service Desk.


I have in the meantime turned off the setting and notifications are being sent normally.

Is there any setting I should activate for this to work?



1 answer

0 votes

Hi Pedro,

Batching notification are sent every 10 minutes because it will get as many notifications as possible during this time and group it to only one notification.
You can find more details here:

Email frequency
Every summary email will contain updates that occurred in a single issue within the last 10 minutes, including changes to any of the issue fields, comments, work logs, and attachments. For example, if 10 changes have been introduced to an issue - 8 in the first 10 minutes and 2 in the following 10, you'll receive 2 emails - one listing 8 and the other listing 2 changes.


Hi Angelica,

Thanks, but that info I already have. The issue I am trying to understand is if there is any other setting I should look into which might be causing notifications from being sent, totally, once the batch notification is activated?



Currently, the only setting is to activate and deactivate the batching emails, there is no other option to configure.
Are the notifications taking longer than 10 minutes to be sent?

Hi Angélica,

The notifications simply stopped being sent.

I activated it around 8:40 and only after I de-activated them, around 1PM, users started receiving them again.

How can I troubleshoot this? Probably better to raise a case with support.



I created a ticket with our support to check the logs for a better understanding of what is causing the batching notifications to do not being sent.
You should have received an email and soon someone will contact you.
Once it's resolved, feel free to share the resolution here to help other community members.


I have the same issue as Pedro mentioned in Jira Server 8.2.3. Is there already a solution on this topic?

Thanks in advance!


Hi Thomas,

I've checked the ticket where our support team is investigating and sending some tests, but it was not resolved yet.
Feel free to raise a ticket on adding more details about the issue you are facing and also if you did some test because we still don't know what is causing the issue.


I'm having the same issue. Batching email notifications does not work. Sending the separate emails is working fine. I did some debugging and my conclusion is that this is due to missing database tables, as I found in the jira log entries like:
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'AO_733371_EVENT_RECIPIENT' doesn't exist.

I recently upgraded MariaDB to MySQL. I don't know if this is related.

Existing table:

  • AO_733371_EVENT

Tables that do not exist within the MySQL database:


Has anyone a clue how to create these 2 missing tables? -> yes, see next reply

Andy from Atlassian pinpointed the root cause of the missing tables. When using MySQL 5.7 it seems additional (References) persmissions are required.

Updated this week to 8.5.3, using Oracle as Database.
Batch email is activated by default - no user received any notification.
After deactivating batch email everything works as expected.

Is there any solution?

Thanks in advance!


Ran through a similar upgrade of 8.5.3 using Oracle DB. Batch email is activated and users are able to receive emails however there is significant delays in receiving them, more then the 10 minute batch setting. In some cases the delays are 5+ hours.

Good evening, I have the same problem with delaying batching notifications with jira updated to version 8.8.1; delays vary from 10/15 minutes up to a few hours; the only solution is to disable the batch or is there an alternative way? thank you very much

We are facing the same issue in 8.5.4 with MSSQL 2014. Can we have a quick resolution?

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you