Base URL is not working

Hi,

on my test-installation of JIRA the base URL ist not working. I installed JIRA with the wizard on an ubuntu server 14.04.01 with MySQL 5.5 and everything seems to work properly except the base url, I can only access JIRA via browser when I use the IP-address. I entered 

http://servername.mydomain.de:8080 

as base url in the systems settings. To make sure that it's not a dns issue I pinged servername.mydomain.de and it is working fine. 

On the server "cat /etc/hostname"  returns the servername and /etc/hosts seems to be okay too.

I used Hercules to check the log-files, the result is:

"Hercules didn't find any known problems in the following log file:

/var/atlassian/application-data/jira/log/atlassian-jira.log"

Can someone help me please? I have no idea what I can do to make access via base-url work. Is there anything else I need to check?

Kind regards

Dirk

 

3 answers

1 accepted

This widget could not be displayed.

Hi Dirk, 

 

It still might be a DNS or maybe a firewall issue.

I would like to check a few more things if you don’t mind.

 

1 - What is the output of hostname -f on JIRA Server? It should returns servername.mydomain.de. If not, something is wrong.

2 - If your hosts is OK on JIRA server, you should be able to login by the FQDN. So, could you try to access JIRA using a command line browser on this server? You can try it using w3m, lynx or another one. 

3 - Can you confirm if do you have some firewall or apparmor blocking the access? You can check it with the following links:

https://confluence.atlassian.com/display/CONFKB/Running+Confluence+with+firewall+on+Linux

https://confluence.atlassian.com/display/CONFKB/How+to+disable+Selinux+and+AppArmor+from+Linux

 

4 - The last test should be you try to reboot this server (if it’s possible) and re-check the network configuration (IP, DNS, firewall and apparmor). 

 

If you are able to access JIRA by the URL from JIRA server but not from your workstation, it might be a proxy issue or a DNS issue, since the DNS from your workstation ant the JIRA aren’t the same. 

 

Regards, 

Renato Rudnicki

This widget could not be displayed.

Hi Renato,

thanks a lot for your reply. It turned out that the dns-record was'nt correct (typo in ip-address, d'oh!)

hostname -f  returned only the servername so I corrected the server configuration, now it returns servername.mydomain.de - result: the base url is working smile  

Thank you very much smile

Kind regards

Dirk

This widget could not be displayed.

Good to know it's working Dirk! laugh

 

Sometimes, the most obvious issues are the most trick, and believe me, it happens with the best sys admins as well...hehehe

 

Enjoy your JIRA buddy wink.

 

Regards, 

Renato Rudnicki

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

573 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you