Auto refresh of remote status in Sourcetree not working!

Hi,

Sourcetree had been happily auto checking the remote status of repos (as specified in Tools -> Options -> Check default remotes...) until the recent update, when it mysteriously stopped working!

I now have to manually tell Sourcetree to refresh each individual repo via the Repository -> Refresh remote status option. This is obviously quite annoying, as I have a number of interdependent projects open.

Is this a known bug in the latest release? Can I do anything to fix it? Just to be clear, the Tools -> Options -> Check default remotes option is definitely checked. Nothing has been changed in any other settings; it just stopped working of its own accord. I am using Bitbucket to host my repos.

Thanks for your help

13 answers

1 accepted

This widget could not be displayed.

If it helps at all, for me this is no longer an issue - one of the interim updates may have fixed it; I'm really not sure! I would suggest that everybody above make sure they have the latest Sourcetree update, although I'm sure you've all done that already...

Seems to have stopped working for me and a manual remote refresh is now required... 

SourceTree 2.3.1
OS El Capitan 10.11.6

This widget could not be displayed.

Auto refresh is no longer working for me as well, and a manual remote refresh is now required... 

SourceTree 2.3.1
OS El Capitan 10.11.6

This widget could not be displayed.

Any update ... still not working on Windows.

This widget could not be displayed.

We are using Stash and SourceTree. When branches are deleted in Stash they are not removed by the local SourceTree Windows client. 

My use case:

  1. See that a given branch exist in the Remotes-node in the project-tree in SourceTree
  2. Manually delete a branch from the same repo (in Stash in our case)
  3. Wait for 10 minutes for the auto-refresh to kick in (my setting is the same as the default) 
  4. Verify that the deleted branch is still listed as a Remote-node in the project tree in SourceTree
  5. Choose [Repository|Refresh repo status]
  6. Verify that the deleted branch is still listed as a Remote-node in the project tree in SourceTree
  7. Do a 'git remote prune origin --dry-run' in the git terminal. 
  8. The branch that was removed is now listed as a "[would prune]" branch.

So, to properly update I need a fetch plus a 'git remote prune origin'

Not sure I understand what SourceTree is supposed to do when one or more branches has been removed in the remote repo.

Re: Auto refresh repo setting:
A. Is the Remotes-node supposed to mirror the list of branches in the remote repo?

 Re. "Prune tracking branches..." option on in the fetch-dialog:
B: Is it supposed to remove branches from the Remotes-node that no longer exist in the remote repo?
C: Is it supposed to remove branches from the Branches-node that no longer exist in the remote repo?

Best regards,

Ronny Hanssen

Hm. I just re-tried my list of actions above. And it seems that the Auto refresh *is* working. However, the manual Repository refresh menu action does not do any difference. Also, my question still stands for what the expected behaviour is.

This widget could not be displayed.

Yup, here too. I set my auto fetch to 1 minute but it doesn't work.

This widget could not be displayed.

Hi,I was thinking your worrey too ,And I can't good work it yet.Dose anyone this solution have?

This widget could not be displayed.

For me even manual action on Repository -> Refresh remote status does not work. I have couple of remore branches deleted (I'm using Stash btw) and they're still visible in SourceTree.

When I'm trying to delete remore branch using SourceTree I'm getting errror:

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree branch -d -r origin/feature/HORST-435 
Deleted remote branch origin/feature/HORST-435 (was 5632d55).


git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree push origin :feature/HORST-435 
error: unable to delete 'feature/HORST-435': remote ref does not exist
error: failed to push some refs to 'ssh://git@stash.xxx.xx:7999/platform/core.git'
Completed with errors, see above

Which is quite obvious because this branch doesn't exist. But thats the only way to get rid off this stuff from my SourceTree remotes view.

This widget could not be displayed.

Yeah this is definitely broken. Replicate by creating remote repo, pulling it, switching branches, deleting remote repo on Github, then try to do anything to the local branch and it throws errors.

This widget could not be displayed.

Not working for since past few updates. I have to always manually "Refresh Repository Status". When is this expected to be fixed?

This widget could not be displayed.

I just installed SourceTree on a fresh new machine and auto refresh doesn't appear to be working.  It was working on my old machine, however, that has the same version of the software.  So, not sure where the disconnect is.

This widget could not be displayed.

Same  problem here - sometimes when I commit something, THEN the view is updated. Worst case scenario I am a few commits behind and have one push pending; I need to rebase and discard all changes in order to pull.

Now i'm teaching all my colleagues to pull before committing anything..

Using sourcetree 1.6.14 and stash.

This widget could not be displayed.

I meet this issue for several months, but at the first of time, it works fine.

I am update to new version bunch of times even to new released 2.1 in Mac OS 10.11.1.

Still can't work. I need manually click the fresh button to get all of remote branches.

But in my own Macbook, it works fine too.

This widget could not be displayed.

Doesnt update for me either. This issue is from 2013!?

Im on version 2.0.2 on Mac OSX Maverick.

I have to do a manual Fetch and tick the 'Prune' option for old origin branches to clear.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

573 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you