Administrative access prompts every change

Hello, I am wondering if this is a bug in JIRA 6 or a problem with my specific install.

I understand that when you login to the Admin console you are prompted to resupply your credentials. I have never changed the default setting and it is set to 10 minutes. However it prompts me not only any time I click on anything, but even during plugin upgrades. This is VERY annoying.

"If you were sent to this page from a link obtained from an untrusted source please proceed with caution or validate the link source before continuing."

This is the message I receive constantly. So does JIRA not recognize that I came from another JIRA page or is this a websudo timeout issue? Please advise.

3 answers

1 accepted

I am experiencing the same problem ever since I upgraded to JIRA 6. However, in my case I have determined that the behavior is caused whenever I have Confluence opened in another tab. If I close out all my Confluence tabs, the behavior goes back to normal. There are some suggested workarounds mentioned in the accepted answer to this question, but I haven't tried them.

Hi Kevin,

I was able to resolve a very similar problem, though the answer was not posted for various reasons.

However this is the link that helped me.

https://confluence.atlassian.com/display/CONFKB/Logging+into+Another+Atlassian+Application+Logs+Me+Out+of+Confluence

Basically what is occuring is this. Your Confluence and JIRA installations share the same Base URL or path but connect through different ports. The cookie that saves your login data does not save port information. This link will walk you through how to change the stored SESSIONID for both applications. When you log into JIRA it creates a cookie. Then when you login to Confluence it is over writing that cookie and JIRA thinks you logged out. By changing the session ID for each application this will no longer occur. The other option would be to change the path for each application. I am not sure of any specifics of your setup but this is what solved my issue.

Cheers,

Rich

Awesome! Resolution Option 2 seems to have resolved it for me (and no restart required). Thanks for posting, Rich!

Hi Richard,

You can refer to this document to fix your issue:

https://confluence.atlassian.com/display/JIRA/Configuring+Secure+Administrator+Sessions

Best Regards

Steven

I have read the article and had found that information previously. I prefer to have the secure administrator session enabled, but it prompts for a password well before 10 minutes.

I have worked around this by disabling the feature during large upgrades but would prefer to have it active. Some plugins would show errors because I would be prompted for admin credentials mid upgrade. I hope this is corrected in future versions of JIRA.

Thank you for your help.

Rich

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

98 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you