400 Bad Request when linking issues after upgrading to JIRA 7.3.4 Edited

I recently upgraded our DEV environment from JIRA 7.0.10 to 7.3.4.  Everything looked great until we tried to link an issue.  Now when we click on More > Link, we just get the spinning circle and nothing comes up.

Our environment is using IIS 7.5 to redirect HTTP to HTTPS and then uses AJP to reverse proxy back to JIRA.  Prior to the upgrade, this setup has worked for several years without any issues.  I submitted this issue to Atlassian and they had me test the functionality by bypassing IIS and going directly to JIRA.  That worked, so they closed the ticket, saying they don't help with any reverse proxy or SSL issues.  Awesome.

When I try to link an issue, two calls are throwing 400 Bad Request errors.  Unfortunately, I can't seem to get any additional info on the errors from IIS or JIRA.  These are the two links that throw the 400:

https://server.example.com/jira/s/c61f7334e942398edd02c712ce03862c-CDN/-zerexw/73015/a03356b5f4f596cb58b4ff9548aa4031/6d8c407be414af383cd711ea317ccbab/_/download/contextbatch/css/com.atlassian.jira.jira-issue-link-confluence-plugin:init-issuelink-confluence,com.atlassian.jira.jira-issue-link-remote-jira-plugin:init-issuelink-jira,-_super,-jira.view.issue,-com.atlassian.jira.plugins.jira-development-integration-plugin:devstatus-dialog-resources-ctx,-project.issue.navigator/batch.css?jira.create.l...

and

https://server.example.com/jira/s/17eede5e2edf6c1a234d35bcf0914c91-CDN/-zerexw/73015/a03356b5f4f596cb58b4ff9548aa4031/6d8c407be414af383cd711ea317ccbab/_/download/contextbatch/js/com.atlassian.jira.jira-issue-link-confluence-plugin:init-issuelink-confluence,com.atlassian.jira.jira-issue-link-remote-jira-plugin:init-issuelink-jira,-_super,-jira.view.issue,-com.atlassian.jira.plugins.jira-development-integration-plugin:devstatus-dialog-resources-ctx,-project.issue.navigator/batch.js?jira.create.lin...

We're still running JIRA 7.0.10 in production, and when I try to link an issue there, I don't see these calls at all, so they appear to be new in one of the 7.x versions.  Anyone have any idea what's different about these calls and why they would be failing when going through a reverse proxy?

2 answers

1 accepted

This widget could not be displayed.

Hi Jared,

We encountered the same problem when we upgraded to JIRA 7.3.6

The problem is with IIS and can be solved easily.

IIS enforces a maximum length for URL segments. Segments are the parts between slashes '/' in a URL. From what I could find, IIS default limit is set to 260.

However, in the URL you listed, the max segment length is 298, which exceeds IIS limit. This is considered as an invalid URL and is rejected. 

To solve the problem, you can increase the limit in the registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\UrlSegmentMaxLength

For more info on IIS HTTP settings, refer to https://support.microsoft.com/en-us/help/820129/http.sys-registry-settings-for-windows

Good luck!

Francis

AH!!  Thank you!!  I've been banging my head against this way too long.  Your solution worked perfectly.

.: Jared

THANK YOU!  Saved the day!  Perfect answer.

Thanks a lot! This bugged us for a really long time.

Just a note: it appears to be necessary to reboot the machine after changing this setting for it to take effect.

Francis, a really great THANK YOU! from me, as well. I had a Jira 7.5.2 installation in the same environment and observed the same problems. After applying your suggested changes, the problems (linking, create issues ...) are gone. You saved my day, too!

Is there a standard that should be followed?  I read another article that indicated to set the value to 2048.  Are there any performance impacts that need to be considered?

This widget could not be displayed.

Well it turns out that thankfully (mistakenly?) the Rapid Boards were not changed at the same time, so in there the URL ends up as 

https://jira/secure/LinkJiraIssue!default.jspa?id=755896&returnUrl=%2Fsecure%2FRapidBoard.jspa%3FrapidView%3D2787%26view%3Dplanning%26selectedIssue%3DTIK-2414%26versions%3Dvisible%26epics%3Dvisible&decorator=dialog&inline=true&_=1521628136117

So for those of you that can't "solve it easily" since you're not in the IT department, just use the rapid boards instead. (Select ticket, ".", "link", <enter>)

(Jira 7.4.2)

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

72 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you