Upgrading Jira service desk results in error 500

doug_redpath July 25, 2018

Hi there,

I've been working on a staging server to upgrade our old Jira 6.4 + Service Desk 1.2.7 to the latest releases.

The Jira update itself seemed to go OK. The instance is now running 7.11. However, when I try to update the service to version 3.14.0 (the minimum version required for compatibility), it results in an error 500 when I try to access an existing project.

The error log looks like this:

 

Cause

Referer URL: http://jiratest.org.uk:8080/secure/BrowseProjects.jspa?selectedCategory=all&selectedProjectType=service_desk&s=view_projects

java.lang.RuntimeException: com.atlassian.cache.CacheException: com.querydsl.core.QueryException: Caught SQLServerException for select "AO_54307E_SERVICEDESK"."ID", "AO_54307E_SERVICEDESK"."PROJECT_ID", "PROJECT"."pname", "AO_54307E_SERVICEDESK"."PUBLIC_SIGNUP", "AO_54307E_SERVICEDESK"."OPEN_CUSTOMER_ACCESS", "AO_54307E_SERVICEDESK"."CREATED_BY_USER_KEY", "AO_54307E_SERVICEDESK"."CREATED_DATE", "AO_54307E_SERVICEDESK"."CREATED_WITH_EMPTY_PROJECT", "AO_54307E_SERVICEDESK"."VERSION_CREATED_AT", "AO_54307E_SERVICEDESK"."LEGACY_TRANSITION_DISABLED" from "dbo"."AO_54307E_SERVICEDESK" "AO_54307E_SERVICEDESK" inner join "dbo"."project" "PROJECT" on "AO_54307E_SERVICEDESK"."PROJECT_ID" = "PROJECT"."ID" order by "PROJECT"."pname" asc
java.lang.RuntimeException: com.atlassian.cache.CacheException: com.querydsl.core.QueryException: Caught SQLServerException for select "AO_54307E_SERVICEDESK"."ID", "AO_54307E_SERVICEDESK"."PROJECT_ID", "PROJECT"."pname", "AO_54307E_SERVICEDESK"."PUBLIC_SIGNUP", "AO_54307E_SERVICEDESK"."OPEN_CUSTOMER_ACCESS", "AO_54307E_SERVICEDESK"."CREATED_BY_USER_KEY", "AO_54307E_SERVICEDESK"."CREATED_DATE", "AO_54307E_SERVICEDESK"."CREATED_WITH_EMPTY_PROJECT", "AO_54307E_SERVICEDESK"."VERSION_CREATED_AT", "AO_54307E_SERVICEDESK"."LEGACY_TRANSITION_DISABLED" from "dbo"."AO_54307E_SERVICEDESK" "AO_54307E_SERVICEDESK" inner join "dbo"."project" "PROJECT" on "AO_54307E_SERVICEDESK"."PROJECT_ID" = "PROJECT"."ID" order by "PROJECT"."pname" asc
	at com.atlassian.web.servlet.plugin.DynamicAuthorizationServletForwarder.forward(DynamicAuthorizationServletForwarder.java:55) [?:?]

 

Should I have installed the Service Desk updates first before starting on the Jira updates? I was following the upgrade path described here:

https://confluence.atlassian.com/migration/jira-7/server_jira+jsd_upgrade

 

Many thanks,

Doug

1 answer

0 votes
Earl McCutcheon
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 31, 2018

Hi Doug,

The main take away here is that Jira and Service desk need to go through the Jira 7.0.X / Service desk 3.0.X version in tandem before upgrading to a later version due to Upgrade tasks that are removed in the 7.1/3.1 and later versions, so you will need to do an intermediary upgrade with both applications installed before going to the latest version.

There are a lot of workarounds and fixes you could try to apply in post such as THIS or the process outlined HERE, but The optimal approach is to get the upgrade tasks applied up front when you have the chance to do so rather than fix post upgrade.

To do this with the minimum steps, set up a fresh install on Jira 7.0.11 installation connected to an empty database that is compatible/Supported with 7.0.X and 7.11.X

Then log in to the staged system with a temp admin account, and install the matching 3.0.11 Service Desk application and any other third party add-ons that you have installed on the source system.

Once everything is installed migrate the data over using an XML backup as covered in Migrating Jira applications to another server, once the data is all in-place on the 7.0 / 3.0 your good to do the Upgrade to Jira 7.11.X

An additional resources that I would recommend reading through is our recently created Atlassian upgrade hub which currently has Jira Software and Confluence Detailed (More to come soon) but the Best practices guide for upgrading Jira Software Server Guid has a lot of really good tips and tricks to help with a smooth upgrade that apply here.

Regards,
Earl

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