Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,816
Community Members
 
Community Events
176
Community Groups

Unable to create sub-task for issue

Edited

Trying to follow the writeup below without success:

https://confluence.atlassian.com/jira064/creating-a-sub-task-720416196.html#CreatingaSub-Task-Creatingasub-task

It states

  • Navigate to the issue you would like to be the parent issue of the sub-task you are about to create.
  • Select More > Create Sub-Task. You will see the Create Subtask screen

 

Unfortunately that option does not exist in the menu for the issue (Story) I am trying to add a sub-task to.  I have seemingly defined issue types and also have a defined sub task.  I also made sure that sub-tasks are enabled in the admin control panel.

 

I am using the Cloud version of Jira.  Is this feature not available during the free demo/trial period?   Not sure what else to try...

 

UPDATE

------------

 

I have defined some issue types, and also the sub-task (just called Task), and it does appear in the schemes.  Attached are pics showing what I have configured.

 

Although my "Story" issue does not show up in the Schemes, I don't quite understand the Schemes screen, I can't add or remove and issues from the list if I try to edit, it only allows me to drag them for ordering.

 

issue_types.pngissue_type_schemes.png

 

5 answers

1 accepted

1 vote
Answer accepted

So it appears there were a few issues.

1) the documentation I was following on the Atlassian site has been deprecated and shows a previous version of the UI which no longer exists

2) the project was created using the "Scrum" process, which is apparently a very stripped down version of Scrum and does not support Subtasks.

3) re-creating the project using "Scrum Classic" resulted in my issues having a new button appear for Create Sub-Task.  Attaching an image showing the button I am now seeing:

 

subtask.png

 

 

There is however another nitpick, which is that now since I have subtasks created, I am unable to see subtasks of an issue in the backlog list view, but you can see subtasks in the sprint view.  I have read several threads on this subject and it was debated quite at length with people on both sides of the fence as to whether or not you should be able to see subtasks in the backlog list, but the vast majority of those responding seemed to want that feature.  I hope it has been officially requested as an optional feature which can be enabled for a project.

Hopefully this helps someone else having similar issues.  Not sure why the system would make Scrum a default process type if it is so crippled and limited, but indeed it is.

Thanks to those who responded to offer assistance, your help is greatly appreciated!

 

Regards,

Matt

If you have already created an issue with named task

  1. go the task and hover to the three dot options
  2. go down & select the convert into sub-task option & from there on, it is self explanatory

Hi @Matt Spaulding! Welcome to the community.

 

Jira treats the issue type Task and SubTask differently.  You will need to add or create the issue type Sub-task to you Issue Type Scheme to be able to create Sub-tasks.  SUB-TASKs are a special type of issue type and you can define issue types to be set at the SUB-TASK level.

Issue Type Scheme with subtask.PNG

Thanks for the reply.  Does it look like I have the sub-task create properly in my screenshots?  I just called it Task it does say it is of type Sub-Task.  Maybe I am missing something else though...

I see that in your first screen shot, that it is a sub-task type, but not when I look at your second screen shots with the Issue Type Scheme, so it makes me wonder if you have two issue types named Task, one Standard type and one SUB-TASK type.  Thinking maybe you have the Task (Standard) and don't have the Task (Subtask) issue type in the Issue Type Scheme.

Oh and, If my memory of base install of Jira is correct, Task and Sub-Task *should* be default issue types in Jira, so you shouldn't have create them.

I went ahead and created a new project, and added the issue types, and also the sub-task.  I'm still unable to see where there is an option to add a sub-task to my Story, I would expect it to be in the "..." menu of the Story but it's not

 

----------------------subtask.png

----------------------

issue_types.png

----------------------

schemes.png

----------------------

story.png

I am facing the same issue.  Did you ever resolve this?

Like Shivani Jayasinghe likes this

Yes, please see the accepted answer above for the resolution.

I saw that and am trying, but don't see how to create a Scrum Classic project?

When creating a new project, you can set the template type, there are many to choose from, under the classic category and also next-gen.  Hope this helps.

Same issue here and I have:

  • A classic scrum project
  • Added the issue type scheme
  • Assigned that to the project
  • Assigned the workflow to the issue type (or default)

No option to add sub-tasks remains, quite frustrating.

I had to end up hiring an atlassian consultant to help me with mine.  I guess the sub-type task wasn't created as the right type of task, even though it was a default setting.  I still not 100% sure what changed, but it works now.

Wow. 

So you weren't able to use the default sub-task and simply assign it to an issue type scheme, you had to create a new issue type and use that?

@Heather Lavergne

I think that's what he did.  I can provide his contact info if you need.  You can email me hlavergne@verdicos.com.

Thanks so much.

0 votes
Jack Brickey Community Leader Sep 12, 2018

can you provide a screenshot of what you are seeing. the answer depends on a few things and this would help me zero in on the issue.

It might be that you do not have permissions to create a sub-task but more likely that you may not have sub-task issuetype defined for the project. You can check this by going to 

project > project settings > workflows and check the issuetypes to see if subtask exists.

Sure, I had replied to the first response above with that info, but I will also make a new comment with that info.  Thanks.

Actually I will just update the OP since it seems like my only other option is to suggest an answer which is not what I want.

Sorry I think I was responding when @Jack Brickey and you were conversing.  Ignore my comment if it isn't of use @Matt Spaulding

@Jack Brickey I do not have any workflows defined yet, I'm just trying to get a handle on being able to create sub-tasks under issues so things like a Story can be broken down into multiple units of work. 

Must a workflow be defined in order to add child sub-tasks to an issue?

Jack Brickey Community Leader Sep 12, 2018

Matt, for sure you have a workflow defined. as soon as you create a project you have a workflow by default. You would not be able to create an issue w/o a WF. Have a look at @Kimberly Deal _Columbus ACE_ input as i'm sure that is the issue here.

I have defined some issue types, and also the sub-task (just called Task), and it does appear in the schemes.  Attached are pics showing what I have configured.

 

Although my "Story" issue does not show up in the Schemes, I don't quite understand the Schemes screen, I can't add or remove and issues from the list if I try to edit, it only allows me to drag them for ordering.

 

issue_types.png

issue_type_schemes.png

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events