Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,290
Community Members
 
Community Events
176
Community Groups

Subtask only inheriting some cfields from parent

Hey,

im currently designing a workflow which uses Subtasks to advance the parent only when all subtasks are cleared. This works fine so far.

I have a problem with inheriting custom fields from parent to the subtasks. All fields are present in the field configuration and are added to the Subtask Types.

Now when i let the workflow create these Subtasks via Scriptrunners "Create a sub-task [Scriptrunner]" Postfunction it will not inherit all fields of its parent. I have tried letting it copy all fields via the mentioned postfunction and alternativly tried defining it more closely with a custom assortment of fields to copy.

Yet when i look at my Subtasks which are created via this workflow some Subtasks are missing the fields completely (not even visible if i click "edit") while others do not.

The peculiar thing is, the missing custom fields are not gone on all the Subtasks even tho i configured them in an identical way.

Example: Parent Issue has CFields "Usermanagement" (Dropdown) & "Cost Prognosis" (Free text field)

Subtask 1 has inherited both fields correctly
Subtask 2 has only inherited "Usermanagement" and is missing "Cost Prognosis" completely even tho it is configerd to also inherit both

I am using different underlying Workflows for the parent issue and the subtasks, both have the cfields assigned to them. We are using Jira Servicedesk Server on Version 4.20.15

Can anyone help me figure out what might be causing this behaviour?

Kind regards

1 answer

1 accepted

0 votes
Answer accepted

As it turns out the affected Custom fields were configured to only be available to select few subtask types and therefore could not be copied over. This has been fixed and is now working for us.

Therefore disregard this post.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events