Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Permission helper not acknowleding project role membership

I'm trying to add a user (myself) to the Developers role in a project so that I can transition issues, but the permissions helper doesn't seem to acknowledge the change and I can't transition issues.

 

The permissions helper:

jira1.png

 

The project roles settings:

jira2.png

1 answer

1 accepted

0 votes
Answer accepted

Quick Question - In the permission Scheme "HS2" does the developer have transition issue permissions?

Answer.jpg

As the permissions helper would seem to imply by pointing out that my account is not in that group, members of Developers should have Transition Issues permission:
jira3.png

@Eric Herot So what are you trying to transition? Because now it seems to be a "workflow" issue and not a permissions issue.

Transitioning was just one example I tried. I seem to be lacking in many permissions that I should have. For example I also cannot assign the issue:jira5.png

Despite the fact that I should have that permission as well...jira6.png

Let me start over.

 

  1. Are you using "Cloud" or "Server"?
  2. Have you refreshed your browser since changing said permissions?
  3. Are you using a Chrome browser?

1. Cloud
2. Many times, including using multiple ways of accessing the permissions helper (on the admin page and on the permissions scheme edit page)

3. Using Firefox

@Eric Herot As a former QA Analyst, can you please try the same in a Chrome Browser. Please make sure your cache is cleared (in Firefox too). I have noticed JIRA functions differently in every browser.

Okay, I tried it in Chrome and the results were the same. No cache to clear in this case since I have never used Chrome to sign in to this account. Is it possible that there is something wrong with the account?jira7.png

Daniel Ebers Community Leader Jan 11, 2021

Possibly - one last idea that came to my mind if there is a "second" account for Eric Herot - as a test or an admin account while the one inserted is actually not the one that should have the rights.

@Daniel EbersBINGO! The "Add Users" widget on the Project Roles page does not show the email address of the user, so it's impossible to distinguish external accounts from internal ones (unless the picture differs). That seems to have been my mistake:

jira8.png

Daniel Ebers Community Leader Jan 11, 2021

@Eric Herot
yes, things like that happen :) Hopefully this fixes it.

The JIRA folks should really fix the Add User widget to include the email. That second "Eric Herot" also has a user account icon that is not showing up in this one place for whatever reason.

And yes this did fix the issue. Thank you for your help!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

7,142 views 8 28
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you