None Of My JIRA Backups Work

My JIRA embedded database is probably 100% corrupted. I understand that. So I'm trying to start from scratch and reinstall JIRA using an old backup. Every single backup I try to restore from gives me the error "Could not find file at this location: C:\Program Files\Atlassian\Application Data\JIRA\import\" Not just recent ones, but old ones that I have used to restore from in the past.

 

I don't understand what's going on and need assistance please, as soon as possible.

3 answers

1 vote
Alex Gallien Atlassian Team Oct 17, 2017

Hi Audra,

Have you checked the file system permissions for that directory? It may be that the user running the Jira service does not have read/write access to that directory. Have you also double checked that the backup file you are using does exist in C:\Program Files\Atlassian\Application Data\JIRA\import\, and that you are using the right filename in the Jira GUI when you are attempting the import?

Cheers,

Alex

Good afternoon Alex,

I've got full permissions and I must have quadruple checked the locations and names. I even am using files moved onto an external storage drive from March that had no way of touching the corrupted database.

Thank you.

Audra

1 vote

Backups get dropped into the export directory - have you checked there?

Good afternoon Nic,

I grabbed a couple from there yes. I tried two from there, one from December of 2016, and one from March of 2016. The latter two have worked prior to today.

Thank you.

Audra

So, if you are copying more recent ones from there to the import directory, what are you doing to them that makes them not found?  Are you changing the names?  Permissions on the files and import folder?  etc

0 votes

Hi Audra,

Given the error you are seeing, Jira cannot see the filename in that path.  Usually when you see this error it means that either the zip file is not in the correct path OR more likely we have not used the correct filename to reference this zip file. 

Windows environments like to automatically hide file extensions frequently, so if that is hidden, you might not be actually entering the full "filename.ext".   So if you're just entering the "filename", in turn Jira is stating that this file does not exist because it is expecting the extension to be included.   You can tell Windows to show these file extensions by following these steps:

 

  • In Windows Explorer (not IE), you can press the ALT key to bring up the file menu, then go to Tools -> Folder Options:
  • Click the View tab and make sure to uncheck the box called "Hide extensions for known file types", then click OK.  We want to see all the file extensions, and unchecking this will do that for us.

Then, if you're sure the file is in that correct import folder, copy that exact filename, with the file extension.  From there you should then be able to enter this filename in the Jira setup wizard to tell Jira what backup file you want to import.

If this is still failing, I'd recommend taking a screenshot of the error message you see and post it back to this thread so that we can better see the error you have having here.

Regards,
Andy

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Apr 22, 2018 in Jira Software

How-to setup a secured Jira Software 7.9.0 on Ubuntu 16.04.4 in less than 30 minutes

...PermissionsStartOnly=true User=www-data Group=www-data ExecStart=/opt/jira/bin/startup.sh ExecStop=/opt/jira/bin/shutdown.sh TimeoutStartSec=120 TimeoutStopSec=600 PrivateTmp=true [Install] WantedBy...

2,118 views 14 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you