Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Next-Gen Completed Epics

Once you complete an epic and all of the stories within it, it still shows on the board. How do you remove it from the board once done?

7 answers

Also looking for an answer on this.  Is the only way to shove them to the bottom or delete them?  Is there no archive?

set the filter on the roadmap to exclude the completed epics

Same here, I have marked the Epic as done and I would like for it to be archived or something sot that it is no longer cluttering up the board.

0 votes


Once all the work for an epic is completed, you should mark it as complete on the roadmap.

To complete an epic:

  1. Navigate to the Roadmap.
  2. Select the epic you'd like to mark as complete.

  3. Under Status, select Done.

You can find more info about epics here:

If you mean that the epic is in the most right column of your backlog board, then it will be removed after 14 days.

I did change the status of an epic to Done (several times back and forth to be sure), but I still see the epic on my board. It's automatically folded, but this is not enough, as done epics will clutter the board more and more. Can I make done epics disappear completely from the board?

Like # people like this

Unless I'm missing something, it isn't possible to move epics to the rightmost column of the board, because epics never show up on the board. 

It is possible to mark epics as "Done," but this doesn't cause them to disappear from the roadmap after 14 days (or ever).

Am I correctly understanding how epics work now?

This is definitely a bug. I've submitted it as a support request to see if they'll create an issue for it in their public tracker, or at least acknowledge that this is a pretty serious design flaw.

Has there been any update on this? Our Roadmap is overloaded with completed Epics and all child tasks have been moved to completed on the board and marked as done on the epic yet it still just sits.

I am experiencing the same problem. Great project configuration, just gets more unusable as you use it!

I don't think there's been any update, but it is now possible to filter the roadmap by epic status, so you can make the ones marked "Done" disappear from the view. This is handy, but unfortunately you need to do it every time you come back to the page -- the filter setting doesn't persist -- or you need to bookmark the URL.

Is there a ticket in somewhere to get this resolved? I'm having the same issue - the roadmap is growing and growing. I've done the steps suggested (marking as done, moving to the bottom and filtering by To Do and In Progress) but would be great to not have to do this all the time!

I'm having the same problem, what is the latest on removing epics that are done from the roadmap view. I'm in next gen.

Many of us have requested this seemingly basic update.  The assumption would be you can use Jira for years.  For those of us that use Epic and Agile regularly this needs to be urgently fixed.  While you are at it @jirasupport Epic roadmap is a great idea but should be tied to the start and end dates of the children below it.  I should not need to update the Epic with a start and end date.  That is a good options.  But a better use, and more dynamic, would be to take the dates of the children if they exists.  PLEASE UPDATE!! Thank you for a good product.  please keep making it better. 

Also waiting for this issue to be resolved...

On the Roadmap viem, press "View settings"

Set it to only show Incomplete

It will remove the Epic from the Roadmap view.

Not perfect but a start.


Screenshot from 2020-12-11 14-51-15.png


This is a great help - thanks for noticing and posting. Much better than setting the filters every time you load the page!

Like eGT Labs Admins likes this

That'll do fine!  Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase

The benefits of using Jira in different departments

Jira is a great tool to use across different departments. Forget that paperwork – switch to Jira and get that tasks done smoothly. Marketing Jira allows for a complete digital transformation of you...

108 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you