Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,415,106
Community Members
 
Community Events
170
Community Groups

Jira Cloud for Excel Functions stopped working

I have some VBA that creates a new spread sheet, then pops in a Jira function

Here is an example.

=@JIRA.JQL("project = CLIENT and issuetype = 'Client' order by summary","key, summary, status, linked issues",,)

 

The plug-in worked beautifully. It would grab the data, everything was right in the world.

Then it stopped working.  I had someone else at my company try it, it doesn't work for them either. 

It looks like it is trying to import data, but just does nothing. 

import.JPGI am able to open a new sheet and click the 'Get Data Now' and have it pull in data, so I know I can connect to Jira.

And yes...

1. I did try a different copy of my workbook

2. Rebooted

3. Made sure it wasn't just me.

4. Rebooted again.

5. Googled

Thanks for the help!

2 answers

0 votes
Dario B Atlassian Team Jun 30, 2020

Hello,

Just to double-check, since a similar issue was fixed on the 24th of June:

Can you kindly let me know if you are still facing the issue or if it is already solved? 

 

Cheers,
Dario

Hi Dario,

It's still broken.

Thanks,

Joel

Dario B Atlassian Team Jul 01, 2020

Hello @jbruno ,

I spoke to the app developers and they said:

The JIRA.JQL() function is only working if the app is opened.

According to the error message the user should open the task pane with our app, then activate JIRA.JQL() function.

Firstly the user has to run JIRA.JQL() manually and then try to use VBA.

If this does not help, please ask them to report a bug using the in-app form:

image (2).png

 

I hope this helps.

 

Cheers,
Dario

Thanks @Dario B ,

I just logged a bug request. (PIF-4535)

As I mentioned in the original post, I had it all up and running perfectly for myself and others in my organization. Then I came in on a Monday morning and it stopped working for everyone.

Let's see what other information your development team needs. 

Thanks again,

Joel

Like Dario B likes this
Dario B Atlassian Team Jul 01, 2020

You are very welcome @jbruno ! 

I will ping the ticket number to dev as well and I will mention that it stopped working on Monday (around Friday last week a fix was released and could have caused undesired side-effects).

Dario.

Is this issue resolved btw? I'm having the same problem :(

It has not. The ticket is still open. 

It looked like my Microsoft Admin had enabled the Jira plug in and pushed it down to all users. 

I had them revert the setting but still having the same problem. I need to ping At;assian support. I reached out earlier this week to try to have a live session with them. No response yet. I'll keep this ticket updated as events unfold. 

Like Dario B likes this

@s.christie . 

FWIW, I am still using the workaround until the issue is resolved. You can put the formulas in, open it in Excel online and get your data. Once the data is in the spreadsheet, load it back up on the desktop Excel and run the macro. Less than ideal, but it will keep you moving for the time being.

Like Dario B likes this

@jbruno has this problem been resolved since?

I collected other errors folks experience with Jira Cloud for Excel and how to fix them. Browse them and see if any of those suggestions help.

A little more information. 

The desktop version is still not working. I tried uninstalling / reinstalling the plug in. No dice.

I was able to get the data by using the online version of Excel, then opening the data backup in the desktop and running my macros.

Anyone got a how to downgrade plan?

it is in the temp folder

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Atlassian Community Events