Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JQL runs into an error Edited

Hi All,

I am trying to create a Board using a simple JQL 

"assignee = currentUser() OR creator = currentUser()"

It runs into an Nullpointerexceptionjirafiltererror.png. Has anyone else also run into this issue? I am wondering if this is from JIRA or any other app we have. 

Also attached the logs here. Any help / guidance is appreciated. 

Kind Regards,

Janaki.

 

2 answers

1 vote

I would want to read more of the logs, right the way to the end of the chain of "caused by", but it looks to me like you have an app that may be blocking access to one or both of the fields you are trying to runt he query on.

If possible, as a temporary test, try disabling the quisapps field security app, try the filter again and re-enable immediately (I think this is the most likely culprit, although you have others in that log and maybe more below)

Sorry Nic, this didn't work. The error doesn't occur when I run the JQL, rather when I try creating a Board using this query. Apologise, I missed to share this info earlier.

That is not unexpected - there are "greenhopper" errors in the log.  And to be fair, you did say "board" in the question, but the "it runs ok as a filter" is helpful to know.

So, I've set up a board too, with some data using the same filter, and I get no problem with it.

That strongly pushes me to question the apps you've got that are doing things with fields.  Did you try disabling the field security app and TMS reports (and any others listed in the error below what you gave us before)?

Did you create the filter from scratch or adapted an existing filter?

If you have added this clause to an existing filter, could you pls verify if you are able to Configure the board after the change? 

I tried the same in a Safe Mode and the issue persisted.

Created a new one.

Have you tried turning off the apps I recommended?  This will give you a different error in the log, safe mode is not going to help us here.

I would start with re-indexing Jira. 

Didn't help either.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,349 views 22 31
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you