Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Gitlab integration goes only one way

I've set up GitLab for Jira as the guide says (got the API token from Jira, added to Gitlab, got the App in Jira). Right now, I'm able to go from Gitlab to Jira via Merge Requests and commit messages (as you can see the issue ID is converted to a link):
image.png
The inverse, however, does not occur. When I do all of this on Jira, no Web Link is displayed, nor my branch name:
image.png
My GitLab Jira integration page (which displays Connection Successful):
image.png

The GitLab integration in Jira is displayed as this:
image.png
What can I do to make it get GitLab info, such as branch, MRs, commits, etc? I've read the tutorials many times and can't seem to find the step I'm missing.

Thanks!

1 answer

0 votes
Andy Heinzer Atlassian Team Jan 14, 2022

Hi Guilherme,

If I understand the situation here, you have Jira Cloud integrated with the Gitlab for Jira app, but are unable to see these commits/branches within Jira.

Just to clarify, are you using this app, GitLab.com for Jira Cloud?  Or is it perhaps some other app from marketplace for this integration?

I tried to recreate this problem in my own cloud site, but so far I have not been able to.  When I tried to reference a Jira issuekey inside a commit and branch name, I am able to see those reference within Jira in a matter of a few seconds.

 

Screen Shot 2022-01-14 at 3.07.21 PM.png

Screen Shot 2022-01-14 at 3.07.45 PM.png

 

In order for this to work though, I expect that you will need to go to your https://{yourcloudsite}.atlassian.net/plugins/servlet/ac/gitlab-jira-connect-gitlab.com/gitlab-configuration

This page is where you can add a namespace from Gitlab so that Jira will be able to see this info.  If this is done, then the other possibility for why this might not be working is that you might have differing user accounts between Jira and Gitlab. I would want to confirm that this is the same user account on both sites (typically the same email address for each account). 

And if that isn't a problem here, then there is also the possibility that Jira's project permission scheme is setup in such a way that your account in Jira does not have the permissions to view the development panel.  If that happens, then you need to have an admin grant you access via the steps in How To Remove or Edit Access to Development Panel .

Try checking out these paths and let me know if that helps.

Andy

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Jira Software

👋 Looking for 15-20 volunteers to test Atlassian training content

Hi everyone! Are you interested in beta testing Atlassian University’s newest (unreleased!) training course? We’re looking for 15-20 volunteers to test our newest training course, Basic reporting...

562 views 20 25
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you