Error: This add-on could not be loaded. It has one or more errors that prevent it from being enabled. Refer to the logs for more information.

Hi,

I'm trying to load a plugin to JIRA and I'm getting this on the Atlassian application logs.

"com.atlassian.plugin.module.ModuleClassNotFoundException: Couldn't load the class 'com.atlassian.plugin.servlet.PluginServlet'. This could mean that you misspelled the name of the class (double check) or that you're using a class in your plugin that you haven't provided bundle instructions for. See https://developer.atlassian.com/x/mQANfor more details on how to fix this."

I have 6 modules on the add-on and 1 of them is not working keeping everything from being enabled. If I just put 5 on the XML, the add-on works, if I put the sixth, the one for the servlet, it fails.

Regards,

Phil | Developer

1 answer

Hi @Phil Dennison Fang , Im facing the same problem. Did you find any solutions?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 21, 2018 in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

1,189 views 10 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you