Error: This add-on could not be loaded. It has one or more errors that prevent it from being enabled. Refer to the logs for more information.

Hi,

I'm trying to load a plugin to JIRA and I'm getting this on the Atlassian application logs.

"com.atlassian.plugin.module.ModuleClassNotFoundException: Couldn't load the class 'com.atlassian.plugin.servlet.PluginServlet'. This could mean that you misspelled the name of the class (double check) or that you're using a class in your plugin that you haven't provided bundle instructions for. See https://developer.atlassian.com/x/mQANfor more details on how to fix this."

I have 6 modules on the add-on and 1 of them is not working keeping everything from being enabled. If I just put 5 on the XML, the add-on works, if I put the sixth, the one for the servlet, it fails.

Regards,

Phil | Developer

1 answer

Hi @Phil Dennison Fang , Im facing the same problem. Did you find any solutions?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

17,657 views 18 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you