Edit Issue is missing fields for 1 user

Before today, this user was able to see all the fields on an edit. Today when he edits, he can comment or change the assignee.

Other users (admin or not) can edit the issue and see all the fields. The configure fields button (for whatever reason) is not on the screen.

What could the issue be for just this user? I even made him an ADMIN to test and he was still limited to the above two fields.

TIA

3 answers

0 votes

Could you ask him to try a different browser?

Sorry, I failed to mention that too. He tried IE and Chrome. And even clean up cache etc, logged out of Jira and back in.

Ok, if you log in on his machine, do you get the problem too?

If you don't then the next thing to look at is custom javascript and add-ons such as behaviours, that might be affecting the UI

Ahhhh, I did not try that. He has left for the day but I will report back in the morning.

I logged on from his computer and can edit just fine. He logged on from mine and has restricted fields! 

Ok, that proves it's his account, and nothing structural.

The only way I can think of this happening is a Beahviour, Javascript hack, or the Field Security add-on hiding fields from the user.

Could you use the developer console in a browser to work out where the "hidden" tag is coming from?  Or even if the fields are there in the html at all?

Capture.PNGI attached a screen shot when logged in as the user. Those fields are definitely display none but have not found the where and why...

new finding: if I edit by opening in a new window, I see all the fields so only on "pop-up" edit, the fields are missing.

Ok, that's handy, but those fields are the ones in the "configure fields" drop-down box, so I'd expect them to be hidden if the button is missing.

This is all pointing to something broken behind the show/hide options in the "configure fields" - is this consistently not appearing for all issues for this user?

no, just this one project for the user. The "configure fields" is unavailable for this project for all users. 

Ah, then I suspect you have a field that is broken in the project.

Could you check the list of custom fields to see if there are any that only for that project, what type they are and if they have any javascript in their descriptions?

I did not find anything but I will continue to dig. One would think if the field is broken

  • all users should experience the same and
  • when editing the issue in another window, it would remain broken....

Unless the broken field is doing something like "if user in group".

if user in group - I cloned the problematic user's (userA) groups to another collegue (userB) and userB can still see all fields on an edit. Also, userA can "middle mouse click' edit to open a new window and see ALL the fields.

Sorry, I was not clear, there are several things, not just group.  There's some data associated with userA that is triggering a break.

Still not making headway (luckily we have a work around).

I decided to query the database table (customfield) looking for any description with this user or the word user or group in it and there are none.

Anything I could try to find from the backend?

This may come with me to the Summit!

That's a good call on the custom field, there might have been a clue in a user-picker.

I'm thinking it's more likely to be something in the data that is stored for them that relates to the "configure fields" option.  I think that might be in one of the "property" tables, and linked to his id.

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

261 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot