Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't create project on jira

With error as follow:

 

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><status><status-code>500</status-code><message>An error occurred while notifying that a project was created</message><stack-trace>java.lang.RuntimeException: An error occurred while notifying that a project was created
at com.atlassian.jira.bc.project.DefaultProjectService.notifyHandlersOfProjectCreated(DefaultProjectService.java:395)
at com.atlassian.jira.bc.project.DefaultProjectService.createProjectInternal(DefaultProjectService.java:377)
at com.atlassian.jira.bc.project.DefaultProjectService.createProject(DefaultProjectService.java:347)
at sun.reflect.GeneratedMethodAccessor1025.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.la

2 answers

Tried restart jira but not work, still get error : Hmm... we couldn't create your project due to an unknown error. Try refreshing the page to start again. Http response same error

Hey there Xue Peng,

If restarting Jira didn't help, then it might be due to a different cause which I suspect is the same one as the one mentioned in this KB - Hmm... we couldn't create your project due to an unknown error. Try refreshing the page to start again. Particularly, Symptom 1 which has a very similar stack trace to the one you are facing.

According to the KB, we can confirm if it is the same cause as the one documented by running this SQL query :

select * from schemepermissions where perm_type = 'user' and (perm_parameter in (select user_key from app_user where lower_user_name not in (select lower_user_name from cwd_user)) or perm_parameter not in (select user_key from app_user))

Run that query, and if it returns any results, follow the solution steps from the KB (but please remember to backup your instance and database first before changing anything major). 

Let us know how it goes :) 

selectresult.pngNo results return from this SQL. So what should I do now? Please feel free to reply.

Thanks for your time:)

Got it, thanks for running the SQL. In the logs, are there any error messages showing up before the one that you shared with us? Anything else related to the creation of the project? 

One of the possible solutions I found online (from another community thread) could be related to the language settings of Jira. For that particular instance, the language was set to German (Swiss German) and after setting it to English, the project was created. While this may not exactly be what is happening to us here, I'd say it's worth a shot to check the language and make sure it's all set to English as sometimes Jira can be finicky with languages.

Change all the language to English (United States) dosen't work.

My jira version is Jira Software 8.2.1, and this error I think is happened from upgrade to this version at June.

errors.png

I've been stuck with this problem for three days.Is there a fast sulotion for this error?

This issue seems to be more complex than we originally thought. Combing through the potential solutions there are way too many things to suggest here. Is it possible to share the entire atlassian-jira log (where you saw that error) in this thread so I can go through it and see if I can dig anything more specific from it?

At the same time, you may want to consider contacting Atlassian Support (if you haven't already) as they may have some in-house knowledge of what is happening here.

I don't know how to insert text file so I take a photo of it.

I tried upgrade jira software from version 8.2.1 to 8.3.2 but not work with the same error.

I tried install a new jira software with version 8.3.2 and after restore old system data(because wo do need the old data), same error again.

Do you have any idea about it?

Or does anyone else can give me a hint?

Thank you in advance!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,496 views 22 32
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you