Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation Not Loading

Rica I'm New Here Jan 11, 2021

Problem

I am trying to access the Automation feature on JIRA, but I can't seem to do so on both the system or project level.  I am the owner/admin, so I don't believe this would be a permissions issue.

In my project, when I go to Project Settings > Automation, I get an infinite loading symbol on the screen.  This doesn't happen for any other project settings.

In JIRA system settings, if I click Automation rules, I also get the infinite loading symbol.

Steps Tried

Any assistance on accessing the automation section would be most appreciated.  I mainly need it within a single project, where my understanding is that the free version should be able to freely access.  Thank you!

1 answer

0 votes
Daniel Wong Community Leader Jan 11, 2021

Hi Rica,

I'm not too familiar with Cloud but I tried testing this and Automation loaded fine for me after a few seconds of the loading symbol on screen.

I noticed Classic and Next Gen projects have different URLs for accessing Automation. You can try using these direct links to access automation on your project (depending on whether you use Classic or Next Gen):

  • Classic
  • https://yourdomain.atlassian.net/plugins/servlet/ac/com.codebarrel.addons.automation/cb-automation-project-config?project.key={projectKey}&project.id={projectID}
  • Next Gen
  • https://yourdomain.atlassian.net/jira/software/projects/{projectKey}/settings/apps/com.codebarrel.addons.automation__cb-automation-project-config

Replace projectKey with your Project Key and projectID with your Project ID. Please note these URLs might not work if Atlassian updates things in the backend.

Hopefully one of them works for you as of time of writing.

Another way I found to access Automation config page is by going to Manage Apps > All Apps > search for "Automation" > click on "Get Started". This seems to take you to the post install page where you can automate a sample project or automate an existing project.

Rica I'm New Here Jan 12, 2021

Hi Daniel,

Thanks for your reply. 

Unfortunately, the direct URLs did not work.

I tried going the Manage Apps route, and got to the post install page.  However, if I try to select an existing project, it doesn't show me my project list -- instead it just says "all projects."  If I try moving forward with all projects and click automate, the page just hangs.

If I say "automate sample project" and click automate, I get the following error: 

An unknown error occurred. Please contact Atlassian support. [object Object]

Daniel Wong Community Leader Jan 12, 2021

That's unfortunate and definitely doesn't sound right.

You'll need to contact Atlassian Support so they can dig under the hood and see if something is stuck in your Jira instance. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

7,193 views 8 28
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you