Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,051
Community Members
 
Community Events
168
Community Groups

Cannot add domain. CNAME check fails

I've made sure to add all the DNS records to our cloudflare.

TXT records are verified fine, but CNAME records still fail. The thing is, the CNAME checks I make from other tools do not fail.

When I check the record from here

https://mxtoolbox.com/SuperTool.aspx?action=cname

or do a `dig atlassian-<id>.domainkey.<ourdomain> CNAME`

I receive proper

atlassian-<id>.dkim.atlassian.net

answer.

But Atlassian cant seem to verify it? Please advise

1 answer

1 accepted

2 votes
Answer accepted

Following the advise on another thread (https://community.atlassian.com/t5/Jira-Service-Management/added-DKIM-on-my-CNAME-domain-but-still-won-t-be-able-to-switch/qaq-p/1521592) I added the following to my DNS registrar:

 

CNAME s1._domainkey.<ourdomain>  s1._domainkey.atlassian.net

CNAME s2._domainkey.<ourdomain>  s2._domainkey.atlassian.net

 

After that, check DNS records button started to fail for all records including TXT ones as well. But I was getting a pass from https://domain-check.atlassian.com/ that showed everything was alright.

Anyways, after 5 hours, my domain is active right now. I don't know what changed. I had atlassian continuously re-check, and just found it is done after I gave up :) Marking this as resolved.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events