Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Can no-longer add plain text, multi-line fields in JSM forms

I've been using JSM forms (ProForma) to make my request forms easier for everyone. Typically I create Jira custom fields for each ProForma field to link the two and capture the data in a manageable way. One common thing for me to do is to create a few multi-line custom fields for capturing a lot of data with specific instructions. Then I will collect the data from multiple fields and consolidate it into the description field via Automation.

I updated an existing form about a week ago by adding two new multi-line custom fields. This time, I received an error warning that linking the fields to the form would convert the paragraph-type ProForma fields to long-text fields. This is not what I expected or wanted. So I reached out to Atlassian, who initially tried to brush me off.

After reiterating that I've done this exact process many times, including on the same form that I'm trying to edit, they pushed an update that would allow me to choose a paragraph-type ProForma field again when linking a multi-line Jira field. Only now, the paragraph fields default to rich text with no option to change it.

So the data I collect from the form—only in those fields—has a bunch of useless metadata. Again I reached out to Atlassian. This time they essentially told me, "tough luck," you can't do that anymore, but you can copy existing fields if you want to hack the functionality into existing forms.


How is this acceptable?

I've attached examples.

2023-01-31_Data.png2023-01-31_Form Fields.png


Update. Their proposed solution doesn't even work. When I try to link the field it tells me I have to use the new paragraph-type field.


2023-01-31_New Error.png

John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Feb 01, 2023

Hi Brock,

Have your tried changing the renderer in the Field Configuration for the paragraph field to not use Wiki style?

That is an option, but I don't want rich text. I just want the old-style plain text, multiline input.

@John Funk, I misread your comment. I thought you suggested enabling Wiki Style for my custom fields. As far as I know, I don't have any control over the new paragraph field type.

John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Feb 02, 2023

You can change whether it is standard or uses the Wiki style renderer with the "new fields" as you labeled them. Change the renderer in the Field Configuration. 

Thanks, John, but that doesn't help. The ProForma field captures rich text regardless of what I do.

I see garbled metadata if I keep my custom fields as plain text. I can swap them to Wiki Style, but then my users are incentivized to add rich text formatting that I do not want.


Unfortunately, the latter is the only viable solution until Atlassian enables plain text paragraph fields in ProForma again.

Like John Funk likes this

Same. I just created a new form and the paragraph fields are coming across with all that junk data. I linked the paragraph to the same field that I used for paragraphs previously, only the new form is affected. 

My old form field is called Paragraph(Plain Text), new one is just called Paragraph

Like Brock Jolet likes this

I have a ticket open with Atlassian, but it sounds like they're blowing me off. It would help if you also sent a request to support so that I'm not a lone voice in the sea of requests.

Like John Funk likes this

It is weird. I can get a plain text paragraph from a template, but I cannot add another one to my form.  Only rich text. I really need a plain text field so my users can upload their Public SSH Keys.

Like Brock Jolet likes this

I would recommend opening a ticket with Atlassian so that this gets more visibility.


Log in or Sign up to comment
AUG Leaders

Atlassian Community Events