Fields displayed on create form changes by itself

Jira... I have my create form configured and when I create a new issue it sometimes loads to a different form completely!   I am not sure what is causing this behavior.

 

Here is the form I want to be using which is configured properly and works sometimes.


  Form A.PNG


Other times a standard looking create form shows up instead... my custom fields and tabs are missing...

 

Form B.PNG

 

It appears to be completely random and I don't know what is causing this.

While other times I get what looks like a mini version of the form...

 

Form C.PNG

2 answers

What URL or buttons are you pressing to create the issue? They don't seem random to me.

1st screenshot seems to be opened to the "Create Issue" URL in a browser supplied with information http://petejira.com/secure/CreateIssue.jspa?pid=10000&issuetype=10000

2nd screenshot seems to be pressing the "Create" issue button on the JIRA site itself.

3rd screenshot seems to be opened by opening the link http://petejira.com/secure/CreateIssue!default.jspa

I use all these 3 ways to create an issue above depending on where I put them.

Gabrielle, I don't understand.  I am using the "Create" issue button on the JIRA site itself in all 3 instances of those screen shots.  Why would a different form be displayed? 

The URL that is displayed for all 3 is https://petejira.net/issues/?jql=

Where in your JIRA Instance are you pressing the "Create" issue button? Are you in your Dashboard? Are you in the System Admin screen? Are you in a project overview page? JIRA will determine what page will be presented to you depending on where you currently are. Try and experiment with that?

I am pressing the create button when on the issues page or dashboard. It shouldn't matter where I press the create button from I want the same form to display each time.

Yeah, that's the factor that determines which create window will show up. I don't know if there's any way to configure it explicitly currently. We can always open up a case against Atlassian :)

Wow thanks, I hope someone from Atlassian can chime it, this is not acceptable!

Could it be that the first one was created from the project issue screen so it knew what project/form to use but on the others you were outside of the project so you are getting a default screen that forces the choice of project?

Agree Jen. That's exactly the explanation of the different create screens.

I couldn't post an image in the comments so I added one below... when I hit next button my fields are displayed

For some reason when I create an issue from the Project Issue screen the mini form is displayed!

Form D.PNG

 

Okay... I see what is happening...


The settings in "Configure Fields" don't seem to be sticking and that is why I get a random form pop up.  Even with the mini form I have the option to "Configure Fields".  I don't see why this is even an option for non-admin users. 

 

Form E.PNG

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

77 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you