Changing renderer has no effect

I changed the rendered for a custom multi-line text field to wiki. But this seems to have no effect in any of the existing issues.

Are there other steps required? Must I fully delete the custom field to change a renderer? Or ...?

2 answers

1 vote

You didn't used to have to re-index, but I've not tested that in 7.1. 

The reason is that the renderers only kick in when displaying the text - the underlying data is the same in the field, it's what's being drawn on screen that matters.  Do the existing issues have wiki markup in their text field?

Steven Behnke Community Champion Jul 19, 2016

Great point. @Barry Kaplan, any chance we can see a screenshot of bad behavior?

I did reindex to no effect.

Yes the existing issue had wiki text which was not rendered.

Screen Shot 2016-07-20 at 7.18.53 AM.png

Screen Shot 2016-07-20 at 7.19.56 AM.png

custom field included in field configuration which is mapped the issue type in field configuration scheme

 

0 votes
Steven Behnke Community Champion Jul 18, 2016

You must also reindex I believe. I don't see this in the documentation however.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

176 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you