Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,888
Community Members
 
Community Events
168
Community Groups

jira timeInStatus("Open") expression is not calculating correctly

Edited

Hi all,

 

I am using  timeInStatus("State") expression in view screen of the issues.  

Sometimes it calculates a wrong value.

For example, for an issue created 3 days ago, timeinStatus("Open") is bigger than issue age itself. 

image.pngimage.png

 

I exported the issue to XML to see exact values 

 

For example 

 

<created>Fri, 29 Nov 2019 15:30:39 +0300</created> 

<customfield id="customfield_11001" key="com.fca.jira.plugins.workflowToolbox.workflow-toolbox:calculated-number-field"><customfieldname>Time in Open State</customfieldname><customfieldvalues><customfieldvalue>8.69492E8</customfieldvalue></customfieldvalues></customfield><customfield id="customfield_11002" key="com.fca.jira.plugins.workflowToolbox.workflow-toolbox:calculated-number-field"><customfieldname>Time in Test Analiz State</customfieldname><customfieldvalues><customfieldvalue>2.6772813E8</customfieldvalue></customfieldvalues>

</customfield> 

 

I re-indexed the project,  but it still shows wrong values. 

 

What can cause this problem? How can I solve it? 

 

 

 

 

 

2 answers

1 accepted

1 vote
Answer accepted

Hey Sevgi,

my first guess is a little issue with the configuration of the display format. Could you please check whether "Use time tracking settings" is checked in the configuration or not? Because that would explain (thinking of the system default settings: 8h/day and 5 days/week) the higher value instead of just counting 24 hours per day. Please let me know if that fixes the issue. :) 

Best, Max

Dear Max,

 

Thank you for your quick response. Below you can see our sites configuration. 

image.png

Hi Sevgi,

you have to check the configuration of the custom field. So please have a look at that.

The misconfiguration of the custom field itself is causing the "wrong value". Which is not wrong but displayed considering your global time tracking settings instead of regular 24 hours per day.

Best, Max

@Sevgi Cakmak,

as your screenshot clearly states:

sevgi_field.png

The configuration of your custom field has to be edited. The field shows the correct value according to your configuration.

Either it tracks and displays the time in a status according to 24 hours day OR as you've configured it, the time will be displayed in "work days" according to your systems time tracking configuration.

So please press "Edit Display Format" and just untick the "Use time tracking settings" checkbox. :)

Best, Max

Thank you very much for your support. It works fine now. 

Happy to hear that. You're welcome Servgi.

Dear Max, 

 

I configured the field as below. 

image.png

There is one more information I would like to share, that some times it calculates correctly. 

But I can not find any pattern related to this. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events