Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why isn't my search returning my labelled issues?

I've added labels to some issues.  I can log in and out of JIRA and open the Labels for the issues repeatedly, and the labels show up.  But when I search for the labels I get no results.  Why would this occur?  

4 answers

1 accepted

1 vote
Answer accepted

I found the problem.  The issues that weren't showing up didn't include the Labels as a shown field in their field configuration.  Once I updated the field configuration and reindexed the system the labels started working as expected.

So the reindexing didn't help.  I can still see my labels, correctly applied, but the search for them gives me a no results response.  Thank you for the suggestion though.

Are you using self hosted or cloud? Is it happening on all labels and all issues?

We have a self-hosted option with JIRA 6.2.3. The search seems to be failing for issues in the project I'm testing, but I have seen results returned for a general search across all projects, using labels I haven't personally added. Though when I use one of those labels in my project, I can't see that specific issue returned, even though other issues with the label in other projects are returned.

Do you have the appropriate permissions to those issues?

If I remove the browse permission I am also unable to search for labels.

After your previous response I was looking more closely and I see that the Labels show up for the tickets not in my project, but in my project they're not displayed. Maybe that's part of the problem, I'm going to look into it.

I couldn't get it to work!  Finally - try Switch to JQL and manually typed in my Label, clicked Search!  And it worked!

I am using labels = "LabelName" and getting nothing back.  I'll try reindexing and giving it another go.  Thanks!

Are you using the labelText: (label) syntax?  You can see more about searching here: https://confluence.atlassian.com/display/CONF50/Viewing+Labels+and+Labelled+Content

Hope this helps!

Sorry, Just realized this was for JIRA and not Confluence.

Are you using JQL - labels = "LabelName" and getting nothing back?  If so, have you tried doing a re-index?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

173 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you