Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA and MySql 5.7 with SSL

I'm trying to setup a JIRA instance on gcloud which connects to a BYOD MySql 5.7 server.

I've created the keystore and truststore and validated connectivity with a simple Java main but when I try set the JAVA_OPTS with the corresponding -Djavax.net.ssl.keyStore= and -Djavax.net.ssl.trustStore= values, I get the following warning:

 

WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate

 

 

2 answers

0 votes

Hello @Ion McCusker ,

Thank for reaching out and as covered in the error message you are going to want to add "useSSL=false" value.  The location to place this is going to be in your dbconfig.xml file via adding the following to the end of the db URL:

&useSSL=false

 and this is discussed a bit further in the following Thread:

Regards,
Earl

Ion - You need to add "useSSL=false&" this parameters in the dbconfig file.

Example: <url>jdbc:mysql://localhost:3003/jiradatabase?useUnicode=true&amp;"---ADD HERE---"characterEncoding=UTF8&amp;sessionVariables=default_storage_engine=InnoDB</url>

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Staying organized with Jira: best practices for a better project management

Project managers know this problem: A “mountain of work” lays in front of you, and you don’t know how and where to tackle them. Different to-dos lie ahead, but just one task after the other can be ha...

222 views 2 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you